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1.1

fej i

WinRunner (BL R fEFX WR) 2T MS Windows ¥ 3 GEMHA T H o

H1T- C/S SRy A D eSS DB , QA FR I TIIAE B BokBoR, T Tillite 4
PR Bk s

WR H] LA B 4R 1 2 A BB T R SR AT 1A FR . AR AT LG ml 5 R m]
SRR A, 1A RO 3R DR AR B . AR A R RS LTS A 2)
PATIXLCIAS, S REAR T S0 25 IO R IR A (R DT DR 1 T 2

WinRunner JUREEZ

MARLE AT b A GUT (BT FEIHD S5, WR 2 F—Fh C A A
T (TSL) AR MIRA . AR] DUF - T4 B2 i) 7 g 4 X A AR . WR ALHE
(Tl BEEi#s (Function Generator) FJ LA B AR FRI ] (5 1) £ L3 sl R0k v iz n
BEo WR LRI B AR

N AR I (Context Sensitive mode)

XA VR IE R GUI X G (Ui W5 3855 SRR 3R (M A E B %
IR R, I 2B IXLERT R A B4 ERP R B . B IR AR A AT 44 K
JIAS o R A T 735 25 08 AR PR 0 R AR IR A E B A

AURFEAT SFEHIIN TH], WR 230 R B BRSSO — 538 JF 5 N GUI map (i) He
GUI map FHBIAA I THORAF AR o A i A A AR, R U B8 GUI
map. IXFEK, PAEEIE A ) I AR A 2 Sy i AT ATH

PAT I A A A . WR B AN A SRR lBOn 5. B A A\ £
#i. WR A GUI map O G dttid,  FTEAEBEI AT T 8 75 5 X Sl 0 4
WR 0] AFE [ — N G R b R B o0t G, BIME AT 3 e AR ik AR 4k

B K (Analog mode)

R R B bR . BTN BUbRAE 4B P R y BilD RS RfIZ S
e AT, WR AL BARRIEHULIZ 5. XA T e 75 218 B Bl bR iz 3l i)
DA AT, o o P Ao
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1.2

1.2.1

1.2.2

1.23

124

WinRunner JU33 72
WR IR AR 43 /SN 3R
£ GUI map

BUEEIIIRES

PRI

AT IR

A MR 4 R

s R

1] GUI map

{4 FH RapidTest Script wizard(PR-I88 i B A AR [ B 41 Y = i, I R Gt agA4>
GUI G K AV INE] GUI map oo A5k 1] LA/ S5 IR 4, ST 50 ok 6t et
ARSI N 2] GUT map H o

R MM GUI map per test #53(, /RA7 LAk IX— P, HAAHN Z7E WinRunner
WETIRE] GUI X8 #15h,

Bt

PRay LA s il g A sl P 2 (W R 77 B R IAAS o SR, AR A A
A S N b 38 AR 2 55 (Checkpoint) o AR AT DA ARG £ 5 KR A GUI X4, 4
Kl (Bitmap) FIE e o EIXAN SRR, WR HHEEAR, JRERIEA A (R
WIS RN A7 Rk

LRz SRR

PRy AR AR (Debug mode) "NIZATIIA . Rt n] LA & H T {(Breakpoint),
MDAz, 2] WR YU AR B AR . R4 R4 fRA74E Debug folder, — HiiA4S
WHCAT LU -

AT

PRAERT IR A5 3 (Verify mode) NIRRT . WR AEIASE AT @ Bk & s, it
2 F A AT S DL A T A AT LA AR B ANAT B, i s B A S5l 45
R
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1.2.5 BHENRLR
DR DAL 2 RO AR AN E o BFINASE A, WR 45 R Bonfefis e s
SR APAT SR D R AR A BT, A R, BRRAE R RGE e
fFR.
WRAERG A B ADFFER I, RA] PALE Test Results G458 & O & F& A4S R
MISEPEE R o W FIRALEAFT S, AR AT AAE H] T s PROYIR AN 520 45 5 2 18] 22 5+
HUETAZIP

1.2.6 & RIS R
A A DA b A BB R T N IE AT R, kR BLELH A Test Results B HiR & AT
ARG B o XL Bl EMAIL Al 2 2 (QA Manager), HISKERERIX A
R HRREE
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1.3

1.3.1

1.3.2

133

134

FEATRA:
ARHFEPIR 2 7 H WR 4711 Flight Reservation(i¥E il ) i+ .

FHIGFEA A
FERBAEAL T 45> F2/7>WinRunner>Sample Application . %2745 2 A~hRA Flight
1A Al Flight 1B.

FERRAEI) Z AR AS

Flight 1A XAMRAE IE 5 44, Flight 1B A5 — S50 I 4% . 7F WinRunner
Tutorial(WR Z7) 1, PIANRCAHR AL FH R FLAH LLAL . A B B8 575 A iAo
AT LAME

Wit WR H1223% T Visual Basic 3CFF, VB JiRA [ Flight 1A Fil Flight 1B K45 25 21
AR A

A
AT P 4 (KRN /D> 4 ANFEFF) 6Bk Flight Reservation(fiiBE AT ) 4, %
44 : Mercury.

WEB JiFE i 3 A1
http://MercuryTours.mercuryinteractive.com; 5% . ifi F-44>F2/7>WinRunner>Sample

Applications> Mercury Tours site
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http://mercurytours.mercuryinteractive.com/

1.4

14.1

1.4.2

15 FH TestSuite(JiREAR)
WRHIIRR S P (6 HoAt, T e 4R AR SR R (e 7 2 WRR TR WA &
GUI it R ER AR 2 H P R G055 7 i S 23R,

TestDirector
TestDirector A= MAE H T H, FBMELN Qi RIFA LN RATEsh. H TD v LT
TR A S e A TN PATIIN PR AR R

LoadRunner
LoadRunner s& H T Client/Server 5 1) /4:(Browser/Server 45445 m] LAAS H) K138 T
Ho DB Z AN G626 iS22 s Ol

%010 4L 127 W



2.1

WinRunner i FH#5id

REEANBUWA TR WR, 748 WR &N E .,

J& 3 WinRunner

®
10:38 Ahd

Rl FF45> #2/7>WinRunner>WinRunner 33 WR. WR [f] Record/Run Engine(it\ 3%/
PAT T 1) P E A5 HIAE Windows 414545 Fo X5 EE % L A 4Ed WR R il 4k
Z IR

A8 WR B BIWGDE [, JRa] UEPSH . 4777 O A7 MR b 7 b
WR. UWRAFGEH FRIANEHRIXAE H, 0l LU Show on startup Fi 11 11)72) 244

wWelcome To WinFunrne: E3 I

WinRunner |

D Mew Test i m .,
Creabe a resw 1esi ﬂc-l"ipt R T T T

Open Tost
Open an e iing kesk acrpk

E Quick Preview @
Wiew 3 Cuick Prawie of WArRunner 1

p Shaw an atarup MEHCUSY INTEEACTEIVE

o110 g 4k 127



WinRunner £ & M
S RRORAYN N
WinRunner title bar 5 8Uf~
Menu bar & HL4%

Standard toolbar FrifE T HA%, A& IZ4T IR H a4
User toolbar F /' T EA=, 447G AN 5 H 1) dr 4
Status bar tR&F2,

WinRunner title bar
Menu bar
Standard foolbar

& Flight Rassrvatics

awt_wicdow ("Flight Bessrvakicn®, 13);
maru_amlack_iten |[Finslysia:Srmpha.. . ®);

¥ Sraph
win_wove ("Graph®; Gii. 3330
set_witelow(*Graph®, 137
ok _pen_text|"F1_Irawiog®, Gext, 5%, 00, ET9, ZE0|i & §4

win_cleosm (TGrmpht|

& Fl:ight Raasrealicz
asr_wikdow (*Flight Beservacion®, |9
Fen_seleot_itew |SFillesBew drdec®|s
oled_uype (PHEHeaRUmA0Lesst, "t 111800 ) E
list_peleos_item |*FLy Fromi*; "Defwer™| ) @ Itam Humbac - = User toodbar
lizt_melech_iten |*Fly Toi®, “3an Francisco®|: @ Itenm Nunbes £ (s
ub]_muﬂ_:l.:ek [FLIGET™, 1&, Id, LEFT|;

Status bar

ERVAN
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A E O
EPAE DA FHAT IS, 7 DA PR
Test Window title bar MR Z AR RS, o M H5FT - BIR 42 F

Test script JMAMIAS, I 5 ) g 5 RS 7 30 A

Execution arrow AT Hik, #§WZ AT IEESAT IR — A7 IIAS, QR A SR 51X bk

BIH AT, T EAEZAT oA B 4 ek BUb /e
Insertion point 4 A&, 3CHR AT LA A B0 56 SCA (1) b 7

ormet_window |¥Flipht Regarvatdca®, 310
o) _TPpE {MSNaa kBnckCLaea ¥ ¢ "AZITEI™ |
Lizy_selent loew ("Fly From® “Frazefuct™)d f Them Mumber 1
Ligr_salect itam (MFly Tor®, MCozdex™ ! & Itew Mimber 1-
ok mouam click | ESETRA, 114 i, LEFT|;

oh)_moupe_click | *FLISRT®, 6%, 33, LEFT):
=20_window |FFlighis Tebla®, 107
Liar_sorivate_ivem ("Flaghi®, "1IS5§ FEA  10:34 AW LoN

i1

Sr_Window |vF3ight Resermaticen, T) -'|
wdit_mat ("W, ®Tokn Fmdih®l;
button press |*Inseet Oedee):
ohd_abeek i | *Inaact decac® Plisbi.ckl® Fguih 1907

ohd_obecl_bitmesp | Traart sosa. .. % “Inqie 5T

%13 ur 4L 127 10w

Test winaow ik bar

Execution amow

Insartion pomt

Test script



2.4 Jn# WinRunner {4
7E WinRunner 3 2, A LLUEPESCHF ActiveX control. PowerBuilder. VisualBasic 5§
WebTest (J4fiffo HARATLFFF LEPAMP ) MI 2w W%, EEISCAS B[R] I 2N T A () 4t
PF, AN B ] BE 20 S I B AT I A 38 i ) R
8 Show on startup Wi [1)2) 2: 45, 1XA4~ Add—In Manager ] % I AN 7E WR A 8) 16
i I AR AT DAZEREAN WR JS7E Settings>General Options>Enviroment LT 15
Fe T AETFAA I s IX A 1 DL S5 A I [R) 45

Add-In Manager I

Select adzHng b load:

[ictives Cortrok
| |PowsEulder

[ Wizua Hasc

| MehTeat

(11 1]]
[w Show o sarup

ok

%14 v 4L 127 0w



WinRunner WA 55 GUI Xf %

KTRG GUI W%

11§ Context Sensitive HH, X448 GUI X} % (4 Windows. Menus. Buttons. Lists)
ATLUG B BISRE L. RS R G — A SO Ja Pt R g & 14T A4k
Mo WR I 22 2] X S8 g PR RDE R, GUI X, AN TG ZEANE N R BEAT B

PRAT LA GUI spy B S 1f0 AR GUI XS 10 J& 1 o AR dn 48 & 1 22 WR i
HAH KM GUI map 15,

WR A GUI map 272K (K5 B AR . 4TI, WR S GUI map & 2%}
%+ Se N GUI map B SN SR IFEIE, AR5 T4 AAH A J@ R 0 5o URm] DL A
& GUI map IRIFXF R A1 & s

GUI map &2 —ELZ > GUI map LA AR 4128 GUI map XA

PRAT LA HEAS AT B> GUI map S, 508 BB & AR B EE A GUI map 3CAF.
ZHWIX ] LAZF [F]—> GUI map Ao 1% a2 WR IR AR L0 07 2256 1 H - oK 3
RAERARRI T BARNEIITS % Global GUI map file $EXF TAE.

WR A LAZERER B EEET AN A 2) 8 EAH G GUI map SCATF, AR ICHHHAAT K GUI
map SCAFEIEE . ORAFBSEICR A 8 n BAR2 WROB T, 3K f ) B R AT e

HAKPN 75142 GUI map file per test 3\ F L1k

LEM LA AT B, AT AE R AR 2 R4 . HAR N 152 %6 3F GUI map
XAt

4 GUI MBS T 25, TRV AT LT HIZE A A . A U5 2448 GUI map s
I3 i R A S 0 SRR, WR G AT AFEAE BSOS B AT 4k B 4exf e, Bk
FE S % 9% GUL map.

PRAT AR E WR AL 2L 1 2500 R 7 1 — 28X B o AR AT BLA WR L3R03 A 5E LY
MG, WA PHEIR S RS BIbRHER Z b2 . AR EIES % ECE GUI map.
PR AT LA WRAE A Ll el 007 K SO BRI G BT VE RN GUI W % . Bk
WEHS 2] BRI

%15 o 4k o127



3.2 PR iR GUI X5
PRI T 57 ) 58 PR OA I 73U R, MR ATE S (TSL) T T BRI AT
BRAF A . HAANZE S Z A1 R
WR 1 F %5 44 (Logic name)s& XXt %: Wi “Print” € X Print dialog box, “OK” & X
OK button. 24544 525 [ 5T GBI FHEFR . PRI IR A & — A5 G v
[R5 B, 4. Print dialog box #% i€ XB— M7 “Print” %#5 (Label) KB, &Hi4
YR — AR, #fAEA GUIXTEE A 5 ME— i,

%16 4L 127 W



3.3

YyERA (Physical Description)

Test Script GUI Map

=l Caca

il e o™

B Tl el
B Finz o ippa

K ez of pachiaicl
H Leckn*

K “Lock rddatcl”
[} PR

RIS R i (2]
HiFsm AT | WREE R
GUL map — %@

Cpean” window labs!

v wtadonsn B ¥ chal

WR S Iy B A UM B DA ) GUT N S W) BRI C0 45 P30 e 1k i S AR
PERIE o XS8R P —(E BCN 7 GUI map 1 LA RS B0 (@1 1: {8 1)@k 2.
{H 2, property3: value3,....}

#ilan: XFT “Open” window HIHHIALL AN EME: 2 (Class) FIdEhr(Label). 2K
JEMERIEZ “window”, ZHRIJEEMIME R “Open”: {class:window,label:Open}

RV JEPERR TR G IS . BN R ZARE D) e AN R &8 T AN [A) (¥ 26 : window, push button,

list, radio button, menu %%,

RARAENRETE . A7 PR PERTE 415 2% GUI map FLE .
TEE: WR EGZAER SO A A RIS 22 B R IO BRE . IR RES X5
QI T — A BRE . HAR N AR S BOE BRI

17 o oH 127 HU



3.4

B%84 (Logic Names)

FEMR A, WR AME F] 4 BB Y BERA KRR B, e R — A4

MHEHERA MERRRE. ZHEEIN, BN RGN — button 124

DR EAERR, W “OK” 8¢ “Cancel”; —A™ window [ FRuE & bR 5L

A A list AR list b7 a5 R S0A .

XA static text (FFASIA) MR, B text FIF-H (string) “(static)” [ 45

o Ul static text  “File Name” [HJi24H 44 /&: “File Name (static)”.

FERFEROLT, AR [m]— AR RO R A AR 2 4 4 0 b — M B AT
(location selector), l: LogicName 1, LogicName 2). HFJZZ5% % —/ME— X FK,

%18 o4k 127 W



3.5 GUI map
4% Tools>GUI Map Editor 7] UI#r%E GUI map [N %. GUImap S2fr & — Pk
A GUI map LR BRI GUI Map Editor W, {8 7] LI E %> GUI map 204> GUI
map AT A . GUL 0 G4 A ATIAE B A vt B BT A 1) 4493 21 47 % GUI Map
Editor [N EANFIEZH 4% GUI map.

HiETEHER

- "Filz namme "
"Fil= name |stahc]’
"Filzz af typa”
"Fil=s af bppe:stabel*
"Laok n"

"Look rlstzhc)”
"Laok n_1"

GUT map fEE T GUT S HANPE-ZFRFE
Bt

19 U H 127 U



3.6

WE B A K (Window Context)

WR 7ERS Gt L B A A5 o 2 SRS IR AE o RS BIAIAS I, — HEY R A4
(Active window) BT HAT GUL X R AHAE, WR 2 HBEMHR A P A — 4%

set_window 6o AR5 T HIN GOl AR B A5 P 45 00 o il

Set_window(“Print”,12);

Button_press(“OK”);

Set_window(“Print”,12)¥5 ] Print window (FTERT 1) & [ % 4. OK button & 7EiX

AN BRI L2 B

WRARF TS A, WIFFEARE A set_window 1] LSS N Y 1 B AR I A2 4k . [FIFE

E 2 B A ISP SRS SR RN B A8 1Y) set_window 511

%20 4L 127 W



FHf# GUI map

XF GUI map

1 WRISATIRARS, SR — AN ZLSE A FH PR 5 (1 GUIL % % SRR BB A T 4
PRI, WR AAZI7 S A GUL

WR 2 S BAF ) GUI SR A R @ . /R LA GUI Spy & (T8 GUI X 411 )&
PE, TR WR 2GR EAT .

WR R BLR U7 0 ) B GUT:

{4 F] RapidTest Script wizard %% > AT RN G AR T GUI W 4 (1) & 1

L 3k S AN 110 759525 S 8 i R T8 43 SR A v T 1Y) GUIT 5 5 1 g 12k

{§F GUI Map Editor 2% > A~ GUI X 5 AR BIEAN G B3 GUI X511 & 1

WA RO R GUT %8 T, AR w] LU GUI Map Editor 551 GUI map.
TEARFFARLE WR 22 S BAFI) GUL 20, AT EEAfAR 412 GUI map SCA #7572
GUI Map per Test mode, A4 BEANFr @ (1A 64— GUI map XA

Global GUI map File mode, #HICHIR LS W] —A GUI map (14

FHOG I BAR N 7515 2% GUI map file B AIIEET .

%21 g 4k o127



42 #HE GUIXNZEHE
WR 2] GUI X R ISR, EMENR PRSI B4 GUI XN RAHIRZ Jw 1k,
n “class”s “label”. “width”, “height”. “handle” F1 “enabled”. WR H 2% >]iX 4]z
PR R — 2R AT AT G AT 1) HAth o S X T
MPRFEE R GUI W JE MR, AT LM GUI spy. 4% Spy pointer #5171 4N X145, GUI
spy St GUI spy Wi HE SR J@ AR ME B . AR AT DL FE A R G 1 B s M el
SUREE ) — A s k.
N R AT SR AT, 4 ) S 1Y Agent Name edit box B, 7E GUI spy
L All Standard Tab L 7<) P 7

FE: ActiveX tab R HE ActiveX #iff 235N 5 4 G B s Hi k.

22 U H: 127 U



7t GUI X% i/ SPY:
1).  #%$¥ Tools>GUI Spy #TJF GUI Spy X iif HE

1E Spy on box 1 fit Windows AJ LAY B A4 1) Jg %
st All standard tab £ 75 BT A AR A4 RN S 1) J@ 7
Rl ActiveX tab &5 AT ActiveX F2Hil i Jg PERI 12 o



2).

sl Spy, SRJFTRITFERE LIOREAX %o IR AWINSE Chighlight), T H 2470 % 1 4
PRy W ZRAATRFN Ggilid R PERME D #B %o AE L X I8

PR R IILAAT RN, R B S MV ISETT AR i 2 S
Description % /N

T R UHERE S AT, 2 dR ) G A T Agent Name edit box B, 7E GUI spy
Hl Recorded tab B W7 N 25

fai GLI S

edit
':ﬁ attached_test Agent Mame:



3). ABHENZRIHIA I E] GUI spy MTEHER, T A0 EUbs TR 17 H AR BT STOP
gt (BRINIRBL 2ol Crl+F3).

e {f Recorded I All standard tabs H., sl Copy button 1] LA G4 BEHk 5 i 21 8Y )i
AL o A5 v SR SR BT, BT AR L AR N AR A2« {class:”edit”, attached _text:”Agent
Name:”, tag:”Agent Name:”}

o 1 ActiveX tab H, RIS —ANEIEN, WUANZJE IO SRR, XA 2 BoRTE
JEG S P A% L
N RIE] T, AR VB RAMTEERE AR B EUbR SR 1) “Flights Table”, 4% T STOP #
5 Ik FE FixAlignment J&PE, 7575 GUI Spy ' ActiveX tab L [1) [ P 45

s G Spy

B RowPos < Parametes(z] required:

E5' ColPos < Paramedesz] required:

Ef' Rowlsvisitle  <Paramese(s) requiied:

B Colls¥isible + Parameter(s] required:

=B hhoutBios

=B fddltem _| ActiveX control methods
= Bamoveltem

=B Fehech

propearty doscription

4). i Close [ GUI Spy.

®o25 T o o127 W



4.3

# WinRunner #3124 #) GUI

WR i 2527 ) A1) GUIL

¢ H GUI Map File per Test mode I, WR 2 7E 3% il AR I 5 2h 2% 3 5 A% GUI
14§ /| Global GUI Map File mode K, FRTFZEHZT WR K GUI X 4@ P 115 B
WR ] L LR 7 AU B R

fi F] RapidTest Script wizard %% > F ARG AR B BT GUI X 411 & 1

T 3 S A AR 1) 7 422 S0 0 s ) RIS 30 - R A o AT 1) GUIT X %2 10 S ik

f#F] GUI Map Editor “# >J /> GUI X%, AR EEAN G A4 T GUIL X% 1) J@ vk

V& : 7& GUI Map File per Test #:X T, RapidTest Script wizard ¥ #5245 .
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4.4

7E£ GUI map H IR B R EH 4

1 AR R EHAE N BUBIAS ThONT GUI W G s A4 I ) 1 ) B, R] BL i A B O ¢
Find in GUI Map. WR 234 GUI map(&{ GUI map file) XS Al & 4: CRA: 256 4T
TF) AR I seax AN R el v A

R : 7F Tools>GUI Map Editor>(#] Jf GUI Map Editor Ji7)>View H.1fii% £ GUI Maps
o GUI Files, %€ WR {E GUI map 5{ GUI map file . T34 % .

WA EARPTLER GUI map SCHF O gk H & A7E gl b 241 JF, A4 WR
T GUI Map Editor H.#F GUI map FI# I 4 £ Hh b A 44

WA TR GUI map SCHF TR0 g Hoo SAER A b D447 IF, B4 WR
¥TFF GUI Map Editor HAE GUI map FIHZI KA N2 X A% %

U R A BN B TR ) GUI map SCAT SN B8R R AER IR AT Hh R FT I, 4 WR
FT7F GUI Map Editor {H A 7E GUI map 321X AN B AR B0 %2
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4.5

GUI map files 1 FHEE:

—/ GUI map STHFASBEAL 25 /A7 A [R] 22 4544 1) B

—/> GUI map ST — AN B ARABEC & AN H R4 B0 £

#£ GUI Map Editor #, W[ LA /| Options>Filter fiy %41 JF Filters(Iii )X TEHE, HRHIZ
WA PRI class 7 GUI map HREX 4. BAANFHIESHIHIE BRI 2.

g
N
o0
=t
\

/

—_
[\
-
=



4.6 GUI map file 15X, LB

THRIFI IR, IRTE 252 GUI map 1 TAEREA

£ WR B T8¢ GUI map JUf#H—k, wJLL#H GUI Map File Per Test £, X i
R, BOCH AR A 3h#H & — GUI map file. 7EVRFAENIRINT, GUI map file [
BIRAT; ERITFFINAR, GUI map file H 3 IH#.

1F2 WR 22T GUI map K¢ A RIS 52, @ iUd B 584 2% 11 Global GUI Map
File #5:. X J& WR FIERIAH . WR6.02 S R AR A HE A F X Ao, HL L REAE

FRX P
T PR R DL R s L
GUI Map File Per Test Global GUI Map File
1 BEANIRRERAT A 1o Qi RO Gl g 1 g 1tk e
GUI map file. A2, HFFEAE GUI map
2. EHJIE, Hagk s il ff file FLAT0S IV R e 1R 18
LN 17 8N% GUI map file. s
3. AENBUINR, RO | 2. RO YRR OLHE
R Gt s — D
Y/ OF
— HBAM GUI AL, A | ZCfERAA AN GUI map
R X GUI map file #REEHT | fileo
il
IRARRS WR WA LR B | aRAR A 45 1) WR ]
=908 AT GUI T2 e, W | # Bl IF GUI 54
PAR I i A 1, Bl A I R AR

EE: AN GEZEL BT B WERAESHI AT A GUI Map Editor 7 2] 1l
A, ARATPLEFRX A0 SOF S i Modify #2BERAE SUE 1 GUI map A FR. 24
WROSKBIIA , XA PR e BUE A . BAR N RIS S BB B2 A MY E R .
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Global GUI Map File (Gt GUI 3B 3C#F) B
T Global GUI Map File #3{

WR A 2% 0 AR 4. — 4P it (155 #BIR IR — % 4 1) GUI
5 o IXAEIXBEAT 55 AT LLAL S GUI map file. 24 GUI K 24E484L, R E&5 0 —4 GUI
map file, AT LAk R4 b AT 5000 3 T4

FE—AWRAL T, FANER (E45) 7T A SRR — N A P R JLAS GUL W%, 1
TN AR (155D MRRIXAN T A ) 3R 5 (g —38 4 B3 fhxd % (s
IAEIEA G AR Pk, AR U SR ikl WR 22505615, WR B AN GRS
R LA R B 2 (R R AR o Bl 17 e e T iE WR
AT SR AT AT GUI X4

WR A JUFP2% S R4 GUI 147515 - 1% Af F RapidTest Script wizard £E 3% il JEIAS §if
—IRPERIZ I BTE I GUI X% . X2 GUI X% Y ELRA AR 174E GUI map SCHFHL.
PR X SR DLIE A P AN 5 S ST GUIT 2% 2] — K

T AR RAT T R R GUI kA48 1k, #R AT LU GUI Map Editor K27 > Bl ) 7 44
BN, IFLLAETEHT GUI map. fRt AT LLZESRHIIIAC T RE il WR B 8))% SIS s
VER) B A BN B0 SXBh v LU PR HLRT B0, (R 2 RGEPEI 2K, SR AR A4 T
IR U AN IX A7 VAAQEF RapidTest Script wizard.

VR HT GUI map file SS2 TIRRMIAS, iy MRS TR RGEA 2 BBl RAF . 1
— HX} GUI map fE B SEAAE LR AE . [RIFEAE DN AR, X 45 GUI map file A2y
W A B n#. #rAT LA GUI Map Editor F L IN4% GUI map SUAF o 412800 V22 AE A
THIRES 348 GUI load iE6), XAFIIAHIZ HAMEAHICH) GUI map LT .
HE: M7 Global GUI Map File #5538 F LAE, WA NZE{E GUI Map File Per Test
AN AR GUI A SIS, X S iliig A7 Ak vl e & il
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5.2 JRFILE GUI Map File
Wiy s, ARmr L vk 2 AR 5 4L 2 7 —A> GUI map.
2R, B> Open X THHE Open button B4k I OK button. K H ZAE GUI
map "1 Open button A, 2 button [ label property M Open 5% OK, &4
41"F: Open button: {class:push_button,label: OK }
FEMRIE R, 2 WR ZEIR A8 5] Open X THAE 2444 “Open” Itf, #i4¥
KA label “OK” [ push button.
] L] GUI Map Editor B o 4 328 45 42 A ELRGIA o /Rt 0] LA Run wizard 763
R BB GUI map. 41 RAEZATINAR, WR A BIHEAX S, it 5347 Run
wizard. VEAIN RS %508 GUI Map.
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5.3 ik WinRunner %3] GUI

5.3.1 RapidTest Script wizard 11 F
RapidTest Script wizard S §E7E WR 6.02 LL_FRieAHAf L PAh e H BEAE Globe GUI Map
File PRS0 MG, 117 WR6.02 BB R RAS B IX AP
7 3% il A HT A8 F] RapidTest Script wizard — R PE2E S E A PR 1 GUL X%, A2
HIHFORAF GUI map ST 5 AERIAS T L 787048 F GUI_load 1) i8¢ X 4> GUI map 3CAF-.
RapidTest Script wizard [¥)1i FH J77%:

1). %&F¢ Create>RapidTest Script Wizard

RapidTest Script Wizard x|

Welcome to the
~cript //izard !

% Sonpt Wizard will create test
#  zorpts 30 you can start kesting
irmrnediately.

To create your scriptez, Script wizard will:
# "W all through' your application.

# Learn your application's
Graphical Uzer Interfface [GUI).

Cancel I Help I

mithi Next.
R AREN WebTest #fi {1 sl HA HE L8401 5, RapidTest Script wizard K445
2).  FRIRBEIRK G RAT T
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HapidT est Sciipt Wizaid

sEFRIT CFRERR), AR5 s Bl DA o Bl AR (1) B AR 44 Bk s 7R 7E Window
Name HEH,
3). EEEWRSE AT

R apidT est Script Wizard

4). EFIRAEE WR B NNERIEA . 21 RapidTest Scipt Wizard 75 #7424 H & A 45 01,
PRIGE PRI S s/ WR B
PRAT AR RE LU JURR S AL A«

e GUI Regression Test (FLII[FIHMR) — HR LB RAEA R A H ) GUI XF 5. il
K —> button ZAHEE . BIEIXFHRNT, WRSEHTE GUI X LR BONE R 7EM
PRI, WR B HT(E EREOA L, JFHRE AT ST .

o Bitmap Regression Test ({7 €] [2] )= J120) — F R LB AR A AN [ A (R 47 & 18 o 28
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5).

BEARAEEAT GUL X%, NERRIX AL . QIR , WR Se Rl He gl #4144
ANEARI— IR B o ERIEMERE, WR 2457 B F LT i b e, FaRes
AFFE T o

User Interface Test(J1] )™ 5 [0 320) — 1% il ik ke e 4 00 4% 14 2 15 7565 Microsoft
Windows Fr#fE. ‘TR

GUI X AL G P A1

. TR RE LSO (text) 7E GUI X% Eaf I,

GUI A% EffEFr (Label) LUK FREE

B GAE FRIg

A O OK button, —> Cancel button, Fl—/M R

FEIXFFPA T, WR R AT UL FEARFS Microsoft Windows A R 7741 4t oK o
Test Template( I USH) — XA MRS Bt — AR BT K A Sl i SR AHE R .
AT H, IR N Al LR IARES (R s,

VER: BV RAARAEE DL EATAT 2R A AR, AR(54R ) LA RapidTest Scipt Wizard K
22 SR A1) GUIL

it Next.

€ SUCSRHEH] (Navigation Control )

R apidTest Scipt wWizaid

B NAERGI AT T RIE SRUE R 74T o SRR EEAE R N B A PR A T 1 345 LA



6).

7).

8).

9).

10).

IMHTHTITEAL R DA%, 7] LA Pause to confirm for each window )2 4] I,
At Next.
1EFE Express(Pik) s, Comprehensive( 4 [f)2% X ike. riili Learn. WR HLITUH RS0 Hh

AN AN T SRR AT o XA R I TR I R TR B 2 e A
JEo

RapidTest Script Wizard x|
Set the Learning Set the [2arning Flaw ta:
Flow & Ernpross

Learnz your entire application
B Application . I | 1 using WinFunner defaults,

1 e
® Application Fl = Comprehensive [Advanced)
T3 [ e 8 e Fauzes after each window and
dialog by, allawing pou to
cuztomize information for improved
test readahility and accuracy.

i

<<Back || Learn I Cancel | Help |

4% Yes 2 No K751k WR /& A EEAEARAEH] WR I, ik WRH 305 33X 4%
Fe

R Nexto

N A B ASFT GUI map SUPFIIORAFBRARFN SO 44, B TR IME .

R Nexto

B NS PR B AR R S 48, B ERAE
st Nexto

st OK 514 RapidTest Script wizard. ARRIZA G I, 7~ 7E WR & 1
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5.3.2 WinRunner Fs% 1K) 7 202 2] GUI

WR 0] Ll i 7F Context Sensitive £, (ERIAFRELL) Il BIAS ) J712:%% ) GUI %
G0 AR T LD B M AF R AE, WR 23 B3 B PaER) ) GUI W% . XA
Trk EAR PR R, A2 AR (R BRI Sl A7 T,
MARFF AR EIN, WR SER B G2 CAAAET GUImap s WIREA, e 2]iX
MPSE S

WR S48 2§45 EUBAE I I GUI map SCArh o BRIBURAEHEH WR I AR LR 17 . T
AN HEES % RAF GUI map.

W RARANA B WR A2 25 SR I 2l I GUI map SCPEH, /RATLAYE General
Options Xf1EHEM) Environment £ ¥ & il WR A IN#iE I GUI map SCPF. VEG0 N A4
%2 %E Global Testing HIH .

SRR, ST U T e o P

5.3.3 WinRunner | GUI Map Editor 2% >] GUI

1).
2).

EFE Tools>GUI Map Editor 11 GUI map i’ 25
Rithi Learns

&7 G Map Editor

2 "Document - WordPad"

= Open
L& usarro - EBEPEIHE

'Fie name:"

'Fie name: [stalic]"
"Fies of typa:”

"Fla: of typec[taic]"
"ok "

Lok, irc[statc)"
“Lock e _1"

-2l Jpen_2




3).

R S AN AR AT IO B, il o B A TR o s e 1727 2 B AP AT

XN, A Yeso
G L AEE S AR, ST AR R AR R . MRS A S B AR T A X S, i
No.

MR ZE ARG, R diE X 5.
QRS (NN AV ER: D)
RSB R L, FEBETT IR ) . WR B 2R (5 EUSHE 24 5T GUI map SCAF .
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54 {&FF GUI Map
PR sl 7720 2] GUI RN, 0 R E A w7 in 2 i i GUI map 3L
I B SO ST IR, DI B & AT AT A B2 WR ORI FRJE 3 WR B, 5
U A A R I I SO s n 2
LEBE G A B MR A NE 1) GUL AR B i, AR 20T IR I GUI map SCAFARAF
FE— MK AR GUI map LA .
JidE:

1). &+ Tools>GUI Map Editor, 1IT4i%H%%.

2).  i%&Ff View>GUI Files.

3).  ffitA<Temporary> 3} 7R~ 7E GUI File 3§15 SCAFAHTA —AME S CO BRI GUI map
AR T o BRI, BT R

¥ GUI Map Editor — o) x|
File Edit Wew Options Tools Help
GUT File:
I*LI:I <Temporaryr LI
findows/Objects:
= e | Lean (57
= "RaEE Medigz |
Add. .
lelete |

Show |
Find §£|

Fhysical Description:

=

LI Expand »» |

4).  {E£ GUI Map Editor #', E$ File>Save ] F Save GUI File X 1A,
5).  IEFESEIE. A (BERAEIUIEAD . TR ORAE . BEIRAFEIY GUI map ST N2
It \B/R7E GUI Map Editor L.

#
(O8]
o0
p=i
N

/

—
N
3
=i



1.
2).
3).

4).

5).

PRAR AT LA IS SO HL R0 8% 8 21— CL@A7AE ) GUIL map SCAFH . TR N R IE S
FEAE A Z M E MBI E

B GUI map SCPFIH N 254847 21| TestDirector [ R (JR%Z0U1H TestDirector,
TR N G S 2% B BRI -

1EF¢ Tools>GUI Map Editor, ¥J H4miEas.

L FE View>GUI Files.

ffiik<Temporary>3CF W77t GUI File 35 5.1 o SCAFA A — AN 25 () R GUI map
AR T o BHRAFE, BT R

GUI Map Editor ', &+ File>Save ¥] 7T Save GUI File to TestDirector X 1A .

Save GUI File to TestDirec tor project |

ﬁguﬂ

F%2 L ogin

%2 Loging

File niame: |F|Ig|'||:T ahble e

Files of type ~ [5LI1 Files [*.gui] =] ﬂl
File 5 pstem... |

PR (BB ST i fRAT
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5.5

5.5.1

1.
2).

3).

Hn#; GUI Map 3t

WR X % 15 BARAFEAE A GUI map SCAFH - R T2 GUI map SCAFR T H0 %
I, RO ZAE SO INEEE] GUI map e ARAENNA T AR HT N4 3E 1) GUI map
G

A PRI EINE GUI map SCAF:

J GUI load Thjfg

M GUI Map Editor ' in&,

R 7] AFE GUI Map Editor H1 25 & 7 IN# [1) GUI map SCAF o IX IS S AESCAR AT TH HY
WA “L”. R0 IFTFF—A> GUI map TR GnHHAHEA N E
HE: WARAEH GUI Map File per Test £, RAGET- TNz E R GUI map 304

i/ GUI load Zhfig In#% GUI map SCAF

GUI load &) i LN AT ATk 75 22 1K) GUI map SC1F. BLAR GUI map Al A& — Pk
Z A~ GUI map XA, HARHBE— R INE—A> GUI map (A ARE M Z A GUI map

SO, @ EAEAS GUL map SCAFEFH—/MEA) . AR AT A GUI load 1 fu) e EIAFa Pl
A TE Sk, ARSI ZIIR CGR— N HATIIINLD Ik XFHREZ) WR I
IR 1 B IN80X % GUI map SCHF. PEAH A 2515 S B AR WIS IR & -

i ] GUI_load & f):

%% File>Open ] FFURAZINESCAFHINNER .

FEDR A A % N, BYLE Function Generator(ZhRE A i #%)H 1i% GUI load ZhRE, A)5
S B N S AR

GUI load(“file name full path”);

#i4: GUI load(“c:\\qa\\flights.gui”);

45 2% Function Generator [ FHi 5% A TN RE

PATIZA I e &S F T .

R WRAR AR GUI map U1, /AT LLH GUI open ZhAEF] JF GUI map Ak
G, T AINEIXAS . ] GUI close ZhAES<HISCfF. ] GUI unload il

GUI unload_all DJfgEI 2N GUI map SCFF. VEAN A 2415 2% B mFR i 77 v
SRR A

%40 U 4L o127 T



5.5.2 Fl GUI Map Editor 1% GUI map 314

1.
2).
3).
4).

5).

JIEZWIRFY

EFE Tools>GUI Map Editor .

1E#E View>GUI Files -

1%+ File>Open.

7 Open GUI File X HAHEH &£ AN ZHT HF 1) GUI map LA«

Open GUI File

ooras [
T

HE: XEAERANBCE R ST IT GUL map SCAFIF N, A AR A AN BEX A S, T kA
&% Open For Editing Only, XFE5E L gmHm A e 1.

siili Open. GUI'map SCAFHINEE] GUI SCAHH Lo U RTINS AT —A “L” 45
WA A DA T .

TER: M TestDirector £ E H N4k GUI map S 5 iER AL, (HIEATHE &
PRV TestDirector 87 BLIX AN -
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5.6

Global GUI Map File £ 5

T e ERE, A LA GUI map SCPF. BN ¥) UT 42 JRCAT 11 sl H oA 10 0]
K15 LA AR GUI map XA

A3 I3 S 4 2 AN RERE U . A SRR AE I AT ] GUI Map Editor 2% )6 %, R AT LA
&4 GUL map TOM R IIBIR A o SRJGLESEBIMAET, 4 7o e A L. 2R AR
TEAB DB IR 2 WS T AR, IC A RIS AT I A T A LRI AN 1B R 4

ANELE WR 223 (1) GUI {5 B R AEIG I, GUI map SCHEEL, PR MR 5T WR I L4
15 B H B RAT o BRAERB I IR, AR — i BEAE G IR AT (- 47 GUI map.
U AR F SRR 7752 2] GUL W%, WR L RE 2 2] IS S o R e i A Ao 42,
AR MR P AT N o U0 SARAREE GUI map B H], 7E3: 15748 ] RapidTest
Script wizard — {22 2] A A% .

MY GUT BRI, S5l A — MR B VE S “GUI Map #HE5Y” 515t 5B
1% GUI map.

%42 4to127 W



GUI Map File per Test 1z F)1# H

T GUI Map File per Test }55

7481 GUI Map File per Test #30, /RANTEEA WR 2222 MR AFIK GUL, A
T ERAZ BN E GUI map SCfF. WR £ A gh5E i Lk —b).

TEXFIEEAR, WR ZEAREIEEH IR % B 3 60— AT GUI map SCAF: ZEARDR
AF AR % A B 0R A7 GUT map SCPFs AEARFT TR A 0% GUT map S+
T FLEThREAEX AR T A

RapidTest Script wizard. T JL7E Global GUI Map File 1= [ A

18 WRJE Bl I FF T — G N GUT map 3CA4(Load temporary GUI map file
box) MITifE. 1FILEE Global Testing IR -

A 3N WR A N# GUI map 3CfF, myinit J& hll 0N GUI map S0, 45 5C /8 8hil
T WA PR ACE -

PRI PR INEk GUI map SCPF. i SR i (RASEERN GUI X% OCHE, R4 0%
L GUI X Gl — 8 AN B LU B (IR AR DG . 1 DL AR gm i RIS .
R H MR (FE GUI Map File per Test #i5 FAIZE) F1 GUI X5 5CHE,
XANMAAE Global GUI Map File #:58 F 247 A A 447 1)

{E General Options X} i HEH ) Environment £~ 1] LLZE#{# F] GUI Map File per Test £
Ko WR EH B EEREASEN.

General Options

Load terrmarang U epfle | ==t oz abar e Eoldens tab|

TEGUT Map File
per TestiR

D MProgram Filessencury Intelazive\winRun |

.
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M GUI Map File per Test F:0E# 51 Global GUI Map File F3X, R4 ZFHEFIAEAN I
X GUI map S FF R — 4Ll A H =30k AR T LR GUI Map File
Merge Tool 3. L& GUI Map 3014
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6.2 GUI Map File per Test #5 T T/
FEIX AT, WR A I s il 1 7 208 ST A 1) GUL. Wi GUT ARk, W]
PLH GUI Map Editor 58 REANER 1 GUI map. 5 JG 75 M2 8/ 47 GUI map SCAH-
TR WARAREAL T X84, YRS H A .
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6.3

GUI Map File per Test 15202 5

ANZELE GUI Map Editor JLARAEARX GUI map SCAF IS 2o PRERAFIIIRIT , JX 4678 5 2
W ABRAT

ANEF TN E B GUI map M. IXEESCAAEARFT TR I 248 B 2hhnak .
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Y53 GUI Map

KT 4 GUI Map

WR i/l GUI map RAR IRk GUI X% . — B GUI 508 T, R340
B30T GUI map "X S HEIR .

PRAT PR B GUT map (1) 772

FEMRIZ AT Run wizard.

MR A a4 WR AR Gt 2 A 3541 I Run wizard. ‘&2 F8 PRSI 5
(R IR 55 21 GUI map M.

H GUI Map Editor F T.4i%H GUI map-

FEARSEHT GUL map Hi, GUI map 200 5E 8 N4k
R WERAE GUI Map File per Test B2, URANAT LLT- TN EGE R GUI map 3.
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7.2 BATAJH (Run Wizard)
Run wizard 7RIS AT HAS I B4R AF GUI 1284 Y WR JGIE @ A B, et
ATIT . ESTRARIRIR RN R, B SRR A PO A, RIS TR B R TT %
Bldn: e n AR @R INEIER ) GUI map SCfF. Z2HEHUT, ©4 H3I% GUI map
AIF IR BB R A AL . XA REEH, R RS, T AT,
WR L& HKEX IR T
EBLRAEM A ALY Open % A £iili Network button. JAIA S B75:
set_ window(“Open”);
button_press(‘“Network™);
% Network button A~ZE GUI map ', Run wizard 5l 2 F1 I 4634 i) 18

Ruwiad &
Can't Find.. “inRurner cannot find the abject
"Mzbeo,

Pr=zz the "Hand"' icon ard then clck
on e object ‘Mebwod:

I:an:::ell (1 Backl rse-:t>.-| Help |

&5 Hand button 4R )5 451 Network button. Run wizard BLE I —MEHTT E .

unwigad B
Solution - Each objec! mantioned in a best sonpt
Add to GLI mugt ezt in the GLI map.

Frezs "OK" 1o add the puzh_bution
"M ebwcrk! ka the GUI map.

W Continue replaying the lest

Cancel | «Back|| ok | e |

st OK, Network 3XN0 5 (U HA L H 20781 2] GUI map B, SRJ5 WR 40470
)l/ito

H
o
%)
=
\

/|

—_
o
2
=



FEAESL N, Run wizard S 4 HNAT A & GUI map. #40, Witk WR AfgHkH
I A ISR AT, B4 Run wizard sl ZE MR A d N set_window i
.
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7.3

GUI Map %828

1%+% Tools>GUI Map Editor 1T . {E4w%H a5 AT AP & F B, A LLERE 3.

#£/~ GUI map
BEEAS GUI map SCfF

& U Map Editor
Fil= Edt “iew UOptiane: Toals Help

s 3

S indowes CObjects:

S eI map th BT BB {00 F .

B RATERRT.

- F RaaTRm
o ﬁ Euitan L=arn El
- ¥ Euitor_1 Moify |
L abl] *Trabz of Flight:"
-3 FLIGHT _oad. |
- = File Dizlele |
- ER 'Flp From:"
-ER Fl To" [
LB rgent Order
- abl] *ame" Show I
L= '"Open Order.." ;I Fird

¥ Shaow Phpsical Descripbon

[ “

clasz window,

RS clazs LA =",

lzbel: *Figt A eservation™

}

kd

|.£'.di'«'c GLI File: <&l mape
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MR B E Y GUI map SCAHFN S, ARAT LR B A5 A~ GUI map S, IXAEAR
AT A (AT SR 2 (B ST R sl iR . TR B AR H4 GUI map SR,
EFPE View>GUI Files.

= GUI Map Fditor M= FE
Fil= Edt Wiew UOptiorz Tpoals Help
GUI Fie ‘
| L1 fignt oo ~1 FTHEIGI I+ S
afndonsObects: SR TERGUT I 4 PR BHET
=1 “Flight Reseraton” = Lzamn El &
—E AT Modify..
! oty |
- 3 Eutton 1 LI
- sbl] “Drate of Flight:" Dzlate |
- £ FLIGHT |
- = File
- EN Flp From:
- E Flp Ta" Show I
- B8 et Order” = Fird
Plyzica Dezerplian: ETIEERB LB R ETE
[ -
Class objecl,
MSW it E,
}MSW_I:Iam Biuttan
5 A N -~
o b | EEMEETIEER ML
|.¢'.di\'-: GUI flz; C:5Program FilesMdecan | nberactives

TEGARAE T, N RGNS N W R G5 ok AARXGE & A4 s &b, ARATELE
BEMUERIAENS. BEEHEWE TGRS, 1E$E View>Expand Object
Tree. M HMEE G, L+ View>Collapse Objects Tree.

MR EFE A GUI map B, /R0 L%+ Show Physical Description check box 3K i 7k
7 Windows/Objects i FL. HH AR 1%L 32 (I S A o MR G .4 GUI map SCEERS, #)
PA A3 SR .

R WRARYE GUI map 'AB T X REEHAL, IIRLAE A T AAAEBEX A5
HZHRA .

R WA S P A S AR A% B IR T, IXAMEL 2T 5 5 K ]

#
(9]
—_
p=i
\

/

J—
\8)
~
=



74 BHOEEL MY E G
7t GUI Map Editor 7 A] LAME HO6) 5 (138 45 44 sl ) LA
0 G T R AL A S SCANT I, ol 75 218 SO A 5 5 B 32
MG EVEEARACI, i S B R . B, —> button I FR M Insert” Ik
J°Add”, R EEAE Y B IR LA label Ja& P 1) (A
Insert button: {class:push_button,label:Insert}, &%
Insert button: {class:push_button,label:Add}
A5
1). %+ Tools>GUI Map Editor 1T T 4i%E 2% .
2).  i%&Ff View>GUI Files.
3).  WIRAHIE GUI map SCAFAR M, WLEFE File>Open 17 3CAF: -
4). X7 Windows/Objects 12 HL & A1) 4 7 7] LB GAR G & I % .
5). HEENZEEERNAL T, R BER.
[ Gurvop Edtor S R[eIY

File Edit Wwiew oOptions Tools Help
GUL File:

| L1 WINKORD. GUT |
findows/Objects:

I—& MsMaskindClass ;I Learn El
=] "Flights Table" Modi fy. .. — S

o T |
: Add .
= Legin —| IEEEESAR

Z

Delet
|:a_l:-]:| “hgent Hame:@ " LI

abl] “Paszword:”
™ Shell_Trayfnd

= "Winkunner FERTE - Show |

*I | r Find EE'
Phy=ical Description:

{ -

class: push_buttom, _I

label: OK

i

;I Expand »* |

IEIb_ier_'t iz not found. Canmot Highlight

6). it Modify 4T JF Modify XJ i HE .
7). GniEZEHAA Y ERER, SEU5 A OK. B UUE BI ALZ) B RAE GUI map U .
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7.5

WinRunner 4&3 R[22 i) & &SR

TARE A AT AR 45 FR. b, Mircrosoft Word 7E4T FFAN R SCAF 4 I SCAR I, 2%
BRI 7R (9 4 T HAN T o

R AR WR %2 20d Ja, T E A BRI AL AE WR ANBERU, A Run wizard
PR RRIXA . — BRI ZE K, WR U XA &R — DR RIAER,
e A NG T B AR K B

BRI T Microsoft Word [ % & . WR 2721 (1) P B IR Dy «

{

class: window,

label: “Microsoft Word — Document1”,

MSW _class: OpusApp,

}

SRJG HARLE Word 4T Document2 ISP T K . WR $oAF] 2044, 547 Run

wizard:

Fian ‘wizand I

Cant Findl.

WirFR urier cannct Find the window
“Miciozolt .. Documert] '

Fres:z the "Hand" icon and then dick.
on e window ' Microsof
Diocumnsne] "

Cannail ::HJ:'.I "l-::-trrl Halp |
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YR &t Hand button 2% )5 5 & Word & I, WR L2 S iIX N E K. #R)5 Run wizard 4>
FEORPRFE GUI map L BT IX /N AR IR s .

Run Wizard E I

Solution - M ew
Dizscipiice Th= physical descriphon of the window
“Miciozaft .. Document]” has
changed
-

Piess "0k to updatz the descriphion in
the GUI map.

T o ta wiean'edit the new description press
Edit

Edt...

v Corvirwe replaping the test

Cancal | d<E!a|::Iq| ar, | Help |

WARAR i Bdit, UR7)BUE 2] WR AU S R4 BRI Bl i ik 2
{

class: window,
label: “!Microsoft Word — Document.*”,

MSW _class: OpusApp

H
XANH RARIE A E WR AE Ui Microsoft Word A4 A Document™ i [ H BL 4 4

o
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7.6

7.6.1

7.6.2

TP EA A A RIB A

WR N T FEX G A oAl A R IA S, s PN Be B . regexp_label Fl
regexp MSW_class,

Regexp_label Ja 1 Xl T & k. EAEfE G 8AE: LRI IRRIA DA — 25 M
#ike VER: 1E Windows 95 ] WR I, XA EIEAZ LA, Jrih WR A
SR EY )

Regexp MSW class JEPEZEXT K MSW _class HHfi AN — 4 IR IE 0. XA E Xt B
2RI B AT object class (X)) XF G HB & A o

YIRS B S VN

fRA] LLIE regexp _label Fl regexp MSW _class J& P IN 2] GUI B & B dn Sl i A4

HAFAEX G IR MSW 2405 0] DA 22 4% 2008 [ 45 , ARl USR8 =
AR R

PRA] LR T AR B IR v ) i R ik 0. EEan ] label J@PEAE D202 ) B g PR o

& #k regexp label JE 1. HAKH HIESHEE GUI Map.

AR IMAIE XL 2 N FUE S5 RIE
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7.7 RIS HIMB SIS
PRa] LU A~ GUI map U HIER 3 GUI X4 2 55— A GUI map SR 7 08
# GUI'map SCHF. VERE: AR BEA— BT FHER RPN GUI map SCAFH &
St 5. WHAR(EF GUI Map File per Test £55X, AN o] LLF T 4T FF5AE SCAF 2 10 & 4
CIgZ DDA
S BAE ShR S T i

1). %+ Tools>GUI Map Editor 1T T 4’8 2% .

2).  i%$ View>GUI Files .

3).  {fEguias bt Expand. X TEAEE S BT IE RN R A GUI map SC1Hs

s GUI Map Editor HE E
Fie Edit Yiew Opions Tool: Help
GLI| File: Gl Fil:
| L1 tightgui = [0 <Temporany: |
SWindowsObjects: Windows/Objects:
= “Fligh: Reservaton' & Learn [ &7 | =] [Flght Reseregion ]
ok R Modiy.. | SR [t ide”
- €3 Button = [Flight B eservation: |
_ﬁ Euul:ﬂ_-l édd
- labl] "D ate of Flight" Diolots |
-3 FLIGHT L e |
- = Fil
ERi © Move |
- "Fly From:!
- "Fly T Show
|- ) "peert Ordar” ﬂ Find El
Ftwsical Descriptior:
{ - Trace | [ d
clazz: object, claz=: puzh_button,
SN i B, |ael: "Dkt Order”
WS class: Bution b
}
j Collapze << | j

|zt GLUI fle: < Tempararys

4). WRAALEM A A F HAD SO/, v LAYE GUI File 35 - JLIERE

5).  AE—AE, EERAEE RIS SRT S . ] Shift Bk Ctrl Zi%. ] Edit>Select All
HPE—A GUI map U 40 % .

6). Aili Copy 5 Move.

7). miili Collapse & il GUI Map Editor.

>
B
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R WERAR N —ANEE I GUI map SCAFHRIIHT & & 21k B GUI map SCA,
SR M ARIRAZ IR N GUI map SCAFIT, New Windows X THHE ST . ‘&SRR
B R B DA N GUI map U BT e AT MR A7 B — A8 ) GUI map SCFH .
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7.8 #E GUI Map File B F[% 5
M AR A B S, AR AT LUR S 5 AT GUI map SCAF R3] & G .
1). %+ Tools>GUI Map Editor.
2).  i%&$ View>GUI Files .
3).  i&FE File>Open )13 GUI map U1
4).  siifi Findo BUbR2 28 1458 17 T (pointing hand).
5). SR S S XA S TE GUI map U .

g
W
0
p=t
\|

/|

—_
[\
~
=it



7.9

1).
2).
3).

4).
5).
6).
7).

7EZ > GUI Map File B F|X 5

WER—ARTRAEZ A GUI map SUAF# B AR, /-7 LA7E GUI Map Editor HLH Trace(#R

i) button PRI H B I A IR AR . AR LE WR 22 ) AT G RF A, 1 H.

R A GUI map SCHFR R EIEMIBR IR A, T2 X A Thagsh kw4 .

(SR

1% $¥ Tools>GUI Map Editor .

%¥% View>GUI Files .

i%$¢ File>Open $77T (J] Open for Editing Only #:X) X} % ik vl G H B GUI map

A

f£ GUI File A HL %7005 120 G s it ik () GUI map SCFH) A 2

7t Windows/Objects £ HL i & iX N4 4 .

Aiili Expand & T XF G HE

Rt Trace. #ARBLALE XA GUI map SCAF 4 Won e XHEHEM 5 —id1,  HAT
SN
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7.10 7£ GUI Map File BF TR
PRAT LUE b 52361 55— ARG IR 1K 7 30/ GUI map SCHHHF LA %o WA 2
B, R AT DA R LA i
PR T

1). ¥ Tools>GUI Map Editor .

2). & View>GUI Files.

3). &P File>Open 11 #1551 GUI map 3CAF

4).  EFAEAGERIERIT S (HOR RS FE AN SR .

5).  fili Add AT T AHEHE.

Add =
o Wanne: |

iq'_-.{n v M anne: 0K
Flight B eseryaban

Cancel |
Logical Mame:

Hel
|De|ete Croer il
Phigsical Description:

=l

claze: push_ button,
lebel "D edets Oder
B

6).  ZiAESEMIAE H G A OKe IXASEDN Gl 2 A in £ GUI map SCAF
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7.11 M GUI Map File B R 5
7.11.1 )\ GUI map SCAFH IR — A0S 10 5 184 -

1.
2).
3).
4).
5).
6).

¥ Tools>GUI Map Editor .

1LF¥E View>GUI Files

YE$% File>Open 3T TTH1 1) GUI map U1

e AR A0 % o T LU Shift 5 Ctrl 36 5%E 20 52
R Delete.

¢ File>Save f£17 .

7.11.2 M\ GUI map A IR 4300 G 10 5 k454

1.
2).
3).
4).

¥ Tools>GUI Map Editor .

1EF¥E View>GUI Files .

YEF% File>Open 3T TTH1 11 GUI map U1
&% Edit>Clear All.
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7.12 #EF& GUI Map File
PRA] LAY GUT map SO At GUI map SCEFIIFTAE A 2. $4E 51k
1). %+ Tools>GUI Map Editor.
2).  i%&$ View>GUI Files .
3).  FTFFMHICH GUI map XA
4).  BoRfi T GUI SCARE H i BT SCEs
5). &EF Edit>Clear All.
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713 FHEEANR
ar LIS BA T ik 77 U0 e GUI Map Editor B 7R IR0 4 .
e Logical name — HE/REAREE A 0EH 4 745 (substring of logical name)
X%, W Close”8 “CI”.
e Physical description — J <& A5 & V) BEAA IR G o AT PR IR o (A 1T
H, W “A” IR AT YRR RS “A” NS BoR.
o Class — HEIRETHEAREE MRS .

AT

1). ¥ Tools>GUI Map Editor .

2).  iE$¥ Options>Filters +] T 9 3% X 1T AE o
Fites [

I Fite by Logical Nams oply |

ID pen Close

[™ Fiker by Physical Dasciplion Hep:

fu
™ Fiker by Class

R -

3). T
4). il Apply. GUI Map Editor £ 7R ik 45 5t
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7.14 {£7% GUI Map I H
E GUI map P &t % 10 12 45 44 R ELASIA 5 /E GUIT map SCHFHP B SO Sl B 4 )i
PRGITAE 25 TF WR TR AFIX LA
RAT PRI T VR AR AT AR B
e {E GUI Map Editor "% File>Save 1"2% T {47 2 #1 5% GUI map L.
o I&FE File>Save As {RA7 2|51 GUI map 3CAFH

o WERIRA—A BB GUI map ST I & A& 2 I GUI map SCAF,

SR AR ERAZ IR I GUI map SCEERY, New Windows X IGHESFT . & SHORIRENIN
B R R O N4 GUI map S B3R B A TERAT B —N 81 GUI map A .
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&3 GUI Map File

XF&3F GUI Map File

GUI Map File Merge Tool (GUI map X6 T H) AVHFEZ A GUI map U5 I
J— A FEA IR, RIER E 2D AR SO R 2 > — A H AR SOF . HAx GUI
map SCPF AT LU DAL IR SCA BIORT SO

PRn] LAE A B E T O M A XA TR

AT, A9 TR AZG IS WA IS G phaE, XEeppsds
Bn=E HARS RS 7s L g e Al

FEF LU, fRAZTF T GUL R GER n2 H s b 250 & TRA SISO
Pl LI UPU PR

FERFELUY, SIF TRAMSAES ISR BT RO P 5.

HIFTERUGE, ARLHEAE GUI map SCIFEEE (1 H] Global GUI Map File mode), il
HAE SUR IR AS 25 28 E A 1) GUT map A
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8.2 &3f GUI Map File HIYER

1).

2).
3).

4).

ARG IFRT, PR E & IFRAL . SRR H bR ST

U (EUIRF

LF: Choose>Merge GUI Map Files

WR 23 th —/NH BHESE R R AT IT ) GUI map SCHRREAER T HL T A AR ORAF I
AR SR BT o

Mt OK 4Kk,

W RARARZE LR A7 AR 5 5] GUI map S, sidhi Cancel J§1J1] GUI Map Editor. 4{R{#
fFaiR e, PO E 1.

GUI Map File &I THITIFIA, ARELAT RS GIFIRM . PSCPERTH AR S

-1 GUI Map File Merge Tool x|

Mer ze
%l [Auto Merge |
—GUL Map Files
Target I _I
Source

TEAIFRIY (Merge Type) HEIEFE H 85 I (Auto Merge) 54F T4 Jf:(Manual Merge).
FE H BRSO, i) it .

WP A CALAFAER) GUI map SCIF, sl OK Ja#7 i iX A 30

B NSCIE A A0 B GUI map SCF.

FRAEW AT
REHE A SO ey STPRAS I BYs SCA L, /R AT LA Ao Browse Folder 1264530
PE¥.

ISR SO R S o b, 5 Add Fileo
A ME SO B E RS SO, SeAE Source HE L E AR IR (S0, SR i Delete.
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5).

silt OK K IR EHE o

WMRARESE H G IE, HaIFd), WR A Bk

WERIRER: A&, ZWESCIFA IS, WR S5 Y EAEE L o 0% 55 OK K
HEAHERT, GUI Map Auto Merge Tool 4T 7. 7 UL B3I&3F GUI Map File F17f
.

W ARIEFEF T4 F, GUI Map File Manual Merge Tool 4T JF. £ IFLEF+ GUI
Map File.

%67 i 4L 127 T



figpk B3)& I GUI Map SCHFRIHISE

H301)F GUI map SCPFI, SAE R I JLAE LT A Az e
PG R AN B IE, (H2 A R A PR

(] B P (KT AR SAT AN R ) B A AHZAT AR [R]K A4 B

Nl A G IR, A ERI BT

t GUI Map File Auto Merga T ool

{PEEHRAE
¥4 A& Buenl Hanzfa=ict! F & o o[yl
loEl _anzel - & ooen statc]”
lelp 249 Carcel
o) K L iggl Help
i.uﬂ Tasmard: e OF
& Farswordfs=iel” —ﬂ "Fasrmoic”
F o Tasswoc[satic]
L 62 Yes
RS TR
HE it
Ptk ezt

RAEMREMIT G, Hpp S IR s e TR 1 5 S RS [R]— T A R
AW G AR F I ERGE, HRE AR
sl Description 25 9% G B G AR M) B A

FHEAR 4240 T DA e I R 58 o T HU 24t SO0 G sl B AR AL P AR s T
XL A REAE I -

TR AF LI it

Use Target (fFH H 45 3C44) {8 H #x GUI map SO BL 0 S 81 44
1132 8 A4 TP B IR R AR e 5

Use Source (i Y&/ § FHYR GUI map SCHF L0 5 8l i AR 1)
TG4 TN B AR IR R T R
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Modify (&50 LR AT RE, AT AT LR I3 A H AR AT S
A rpon) G B R B AR P i 5
KR . YRAT LUE SOX AL -

Modify&Copy (&SRR G AU SC AT RO B AT M B A A R
il R h 5 o
FER: VRITARE AN S e DRAF AR PR S A F
Ho

URTE ZANE SO TR A AFAEPPSE, AR 0] LA Al Prev. File 8¢ Next File K4 .
IR —ANE SO AR 2 AN e, VRATLL S Prev.Conflict 5 Next Conflict K 47) ¥ .

— FL T H AR SCPEAYS SO 2 0] i S ok e, S A sh e it B R —A4
ARG RFTIT e 2T MR G, R BV SR H AR S (A7
TEPPSEHI SR #woe k], H. GUI Map File Auto Merge Tool 123541,

TR

A, ARTE 2RI SCIE BLAR Db S 7 VAR 248 T T FAB YR SO ((H X S ok 5 7%
PRANKEHH SR it e FoAh 95 SO L 58 ) o 3X I, Remove File 32412 L. sidifE, 24
HPESCAT R AR SR S B R T

ot B AR SO AE Sess i A B ERAT -
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8.4

).

2).

F LA GUI Map X

WRART T4 JF GUI map 3CAF, BEAN H AR STHHRER 2 U SO R G 0. & 0F T RS
1ERTE G I il R o .

FLAIFE, HAx GUI map SCAAAEL A DL R N %5

PR AR A, (2R IR AN ]

P T ARG A [) 42 FRFIRH )4 BE A

— A EART AR R A FE IR, HE PR R AR

— AT A R AN R GG A (] A4 PR RUAH [ P B A O

N AT LA I R AR T

4 GLI Map File Manual Merge Tool

:_h[l "Ageni Name"'
& hgent [ztabc”
i o et L W Cance Cancel iEiEE
Help
bl “Pazzwond”
A "'Password: [slabic]”
A "Paszmod [static)' B ‘ez

T LA IR %

549t GUI Map File FIHESAHLL, EPEE 2% Manual Merge. 1% & ISR H
bRt i OK J5, GUI Map File Manual Merge Tool 5t 23T FF . J5 SCA-AN H by S04
RN A2 o k.

P St DA AT KNS



3).

Xk B A RT LLR B B AR S IR 4

WA ZANE SO, W LL AT Prev. File 8¢ Next File 1] .
Rl Description 25 F #1524 G 8 AR T W) EE R A

LA R 45 I8 1 -

T HFIEI

fhik

Copy (X Gl i F e ISP i
FEREA T D)

MBS A IS5 B G el 4 A2 1 3
HBR S 1R B AR B A B A v

VER: ST AN 2 [ I A2 2 o i
xs 5.

Delete (4% 5 ol B A AE H ARSI N
SE AT D

IR SO MR A o0 22 RO 5 i 1
FER: MBS fA I 2[R I 2 4 o i
x5

Modify (%58 G R7E H AR SO 4o
SE AT D

77T Modify XHHAE, (&2 H BRSO 4
INSEIR 5 B A 4R 4 B AR o

Modify&Copy (95%] % 5, A 7E 21 Y S
Al s s ARy D

17T Modify XIRHE, A& XSESCAF N
SR G B AR IR B PR IE, IF A
T2 H ARSI 0 B AR B T A

FER: ARAESSCIE RS A S IR AT
TR

i A I MRS AT LAUH Remove File MG L Fis B A% H bR SCHHY

Bl 2 H B R AT
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8.5

%25 %) Global GUI Map File #=,

M GUI Map File per Test #3245 %] Global GUI Map File #3,, 2 JIuE % TR
et I GUI map XA e G54k, ARG LA A Y AR -

B EUA SR, VRLATINZIER ) GUI map AT

YRAIIALE General Option %+ Global GUI Map File #55, fRA74AF S J+ 587 3 5) WR.
MIELLS, A% GUI map SCAFASIR AT AT B SR O 20 ORAF o
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FE GUI Map

K THE GUI Map

B ERAF A GUI MR EH Z M@ PE, W class (38). label (#5h5r). MSW._class
B MSW_id (BB AP IRRT ) x (X ABRFR) y (Y AFR). width (%8

J) Al height (%), WR £E Context Sensitive J32 B 5 F X 6 g MR bR RN 52

2 WR NG, EIEAN I G A B @ 2, TS5 > A] LLER VRME X B ) f 2D

JEM . XA A2 (U push button, list, window,5¢ menu), WR 23] ERIAFH—41

JE Tk XL GUI map B .

filr: —AMARUER push button 5 26 Mg, W MSW_class, label, text, nchildren, x, y,

height, class, enabled. fEZHIEHL T, WR H T2 class Al label il n] LA G — /N —Fx

PORIRAIX S push button.

V2B B g XK GUL X S . HE SO GFAT AT L WR AT H I FRAEXRS 5

B . Bk, X0 IHE— B % It 2 WR ARSI E s — 3 E X

W, AR A A B obj_mouse_ifi ).

R B SO G — AR GARL, -] DUE s 3 —MrdEx 28 IR

WA DARC B WR HR N B g MR I JEYE . TR 2 it 2R E, #8 X B T 411

AR ZERR P o AR R X PR B SR BT B, R 0 I BV POV N 213 sh IR A o

FEORAR A B WR, 3 8 AR AR 25 05 X AN

R WARR A B ) button, R0 DAEEAT AL 21—/ M5ifE button 28

by AT BRI WU IR /RAT LL{E General Option X1 fiE Record £~ L

Advanced Record Options /'] Record Owner-Drawn Buttons H.3i%—/™5##E button 25,

PRt n] AAE A 3 rec_owner_drawn MXIE LA setvar Dy fiE . 755 General Options

XHEHETE DL ¥ B Global Testing &I . T setvar ThRE, 1 WM BIAS i B WK

XGRS NPT SRR . AT BN CLREEME— & 1),

MSW _class 8t MSW_id. fU82 83 CLFFZ 6, (A ME s,

handle,5¥, Toolkit _class. JLAM#SE5E4T[F25), Wl label, attached_text, enabled, focused

oY, parent.
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9.2

¥f# GUI Map HIBRAELE

XFFREAIOKYL, WR A — BN E k. BENERIN R PEA B 20 1l “ a2
(obligarory)” B¢ “H[iE Coptional)”.

obligarory J& 'k HEEAF7E WR Bi—E %% > .

optional J& 45 obligarory J& AN AE LAS& HEME—FRIR KT IS AT H o X L8] ik Ja 1

SEAFAE— NG B . WR G B e /2 DAME —FR VU0 R s NCR I J@ M. e T
AR AN EYEITAR, — ML ME RS I ERGA R, E R DAIE—FR IR 5

W AR GUI Spy £5& > Cancel button [FJERIAJEE, FREFEF] WR 24>] T class Hl

label J&E. 1X/> button JP)HHHIAZ: {class: push_button, label:”Cancel”} .

FE W ZRURH ] Ja8 P AN REME— AR O G, WR A — AN IE$E F (selector). BiltT: 1
RGP H P OK button #RAT [FIFE 1K) MSW_id, WR £l FIZEFEAFRIX 3BT
PR PR

P EIEFEFF (location selector) FXT BN E (LR A4,

RI|IEFAT (index selector) H—AMME— R RAR IR — DB P IS WX
PEE T RER AR, BB IR PR
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9.3 A RS BIARAERIR
AT WR AL AR ARAE R B0 GOt 2 H 7 SO Ge 25 I 38 B 4
WR Htffi ] obj mouse iff].
ik GUI Map Configuration XJ UiFAE, /RATLAZ WR H & UG IS WL B —AMr
S A9 - Bl A AT — > WR ANBE R H € X button, WR AT i i73X /> ) button
34 5 B obj_mouse_click. /A LLZL WR FEW S 2 Fr#E push_button 2. UG 244k
RiFIXAN button I, WR B4 5% A button_press.
T B SO GBI BRI AT AR ARHER th 2o EEIARAN REAE A 8 X
push button B £ edit 2.

H 58 SO GRS BIRRHESR ()45 07 v
1).  %F Tools>GUI Map Configuration. Class i ¥ 107K FTA AR HESREAT WR RAH I B &

GUI Map Configuration E |

Clazz Lizt:

CUcheck Bulbon &dd..
combinhng
edit
frame_mdic-lient ﬂl
listhioe
rdichent ElanfEuhe..
mditent onigare. |

micaddontable

risctls_slamshard? ak
]:ﬁr\:flq brmr khnr.i? _ILI =
4 ¥

2).  widi Add FTIFAS ISR .
7 |
Class Name: | @ Cancsl |
Help |

3). A TFREAR G SRS ISR . H i B4 FRE HILLE Class Name
HEHL . IXAAFRAENT S A MSW_class J& P HI1E
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4). i OK SCPAXUERE. B iniZe S 1E Class 36 B0 802, 1 Har &A1
“U” (user-defined ] /7€ X))o

5).  fiili Configure F1 JFAC & XS HAHE o

Configuie Class [ =] I
R el

g \uﬂ-m
Class Name: IRIS. brapbuticon — Dielaul | oK. | BENAE
Mapped ta Class: o
Concel | (=]
Help |
Awalable Pioperties: [~ Learmad Propartias
dizplayed 0 bligatory: Optianal: Selector:
widih class atached_text
rum_columnz reoosp MSW_cla: |WSW_id
u lahel MW _clars " Indes
Y
ahs_w % Location
abs v ;I
[if==1]s I Imsert [rsert
Record Mathod
’7 & Aecod " PaszUp = g Object i Ignare
Gerelaled T5L Script :
zet_clazs_mapl("IR1S bapbugtor. abject’]:
Pacle set_record_ati] ‘1A15. brpbotton'’, "class recesp_ M5 _class |
= zet_racord_method " IRIS. brapbutice”, BM_RECORD):
4] | 2

6).  {t Mapped to Class ii§ {111, CEFEARAZEMS IIPRIHESS . e, RHTHES Boxix A
R GUI map FLE . PR AT MBS A E SR GUI map BCE (BLFRZEA 2] R P

PEPERF RIS 5
7). R OK 52t &

EE: RERGEH TR, MEK AR X ANNE, /R 2HE TSL 15 AR
A S HA
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9.4 BCEFMERH E IR
X FAEATAR R AR, AR MBS BL R &40«
o RIMENE

o IEFEFT
o AT
B Irik:

2). ¥t Tools>GUI Map Configuration ¥1JF GUI map FiC B XTGHE. ZKIEH (Class List)
05 T BIRRHESS DLAARES IR B 5 K.
GUI Map Configuration |

Class Ligt:

H 3 tl.l't.l.:lll.'.lm"“"“"m" Edd
comboho
edil
frame_mdiclent ﬂl
listbices
ridizient Cofoue...
mhic_i_win Lonhiguis |
micaddontable
rrectl_slanshards -

& r

3). MIEMRARERCEE, 5 Configure. MU 'E I IEHERL 4TI
]
TR O HEANZE

r
Cla==s Hame: edit Dafanl t I 0K I

Mapped to Class: [odi: =] Eemacil |
Help I

hwailable —Learned Froperties

Oblizatory: —7— Optional: Selector:
cla=ss MSW_1d
num_coluamns attached text ' Irdes
; _ e ral | B
abs_x % Locatia EIRE=E =4S
MSW_cla=s=s
abs_y |
PR AT REE
Insert I Insert I Insert I
—E d Mezthod
SeeRe TeRe BT
i* Becord i~ Pass Up " A= Object i Iznore

Generated TSEL Secript

zat_record_attr (Medit™, "clazs attached text™, "M

Fazte I set_record method(edit™, EM_RECORD);
<] | i
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4).
5).
6).

94.1

1.

2)

3).

PRA] LB S 2 B P, IR BT Bl il 7%
B e UG Rt OK.
7E GUI Map Confguration %] iHHEH it OK.

e B S R e

XIGHES Learned Properties 1X— 1~ fCVFURIC B 28 Uk I 7 ST R M. ARAE—A
TR IERE AN E M, EURARESE A Z B TS 5T s Insert. BN R M A8 HIL
TE—MEH L

Obligatory i 5. AL 7 b2y > 1) J@ ok

Optional i 5§ _F ¥ J& P 2 A Obligatory ¥ 5. F ¥ J& PEA 2 ASR AL ME— BRI 1 I A4
BAL ] . WR ATE B2 — AN @ I IG,  dREn] LAME— AR 00 Rl MO ) JE - (an
FHT AN E R DAME—AR 5, A A S DUAS T,

Available 5 5. b (1) ATE RTINS S LA H AR AT Ak

AR T

SRR S B, SRIGAE HERTG 5T fidi Insert. {540

A label J& 14 M Obligatory ¥ 5.5 5/ £1] Optional i 5, 7E Obligatory ¥ H sl /™ J& 7,
SR JG7E Optional ¥ 5. K st Insert.

WERAE — ARG 5 ERHBR A A2 2], nTLAAE Obligatory ¥ #.8% Optional
W E XA E M, SRJSTE Available T T £iil7 Insert.

MZHENEH b & HEFINY OJCILAE Optional 35 5111, mi—NEEZANEME, IF
AT N Inserto B 0 (10 & 1wt 2 R 21 2035 54 1) SIS

st OK DRAF FT I 2

R AEPATI R PEAGE I T il 3. i JE MRS 1 15 B .

JEE(Property) Z;(Class)

abs_x FIEcEN

abs y IREES

active GiREES

attached text combobox, edit, listbox, scrollbar
class IREES

displayed GIECEN

#
-
s
p=i
\

/

—_
)
23
=




94.2

943

enabled IREES

focused VIEES

handle VIEES

height RS

label check button, push_button, radio_button, static_text, window
maximizable calendar, window
minimizable calendar, window
MSW _class IREES

MSW id P (5 T A
nchildren RS

obj_col name edit

owner mdiclient, window

pb_name check button, combobox, edit, list, push_button, radio_button, scroll,
window(object)

regexp_label P £ LB FR )

regexp MSWeclass | iITH 2

text VIEEES

value calendar, check button, combobox, edit, listbox, radio_button,
scrollbar, static_text

vb_name RS

virtual list, push_button, radio_button, table, object (virtual objects only)

width IREES

X IEEES

y IEEEN

W L FERT

TE W ZRAN ] 3 S/ PE A AN REME— BRI R ME LT, WR A HIEFEART: location B index.
location iEFEFFARPE X G AE T AR IO S (N EBIR, MWAEFRIA) SRikF. index EFE
FERR 4T RN DL BL2B X G e —$0 7ok ik $E . WR ERIAEH location ZEFEAF .

LN IDIRES
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STV E WRAE SR8 T2 — 20 Gy R HI )84 07 2o — A7 DU AT H 7 5K
Record fif WR Sk HEA GUI MR IFTATERAT . 1X7E WR ERIA RS FrAT 2K 1K =il
Ko (ME—IBISME static 28, XAFEHERINTT UL Pass Up. )

Pass Up & WR K HD0 0 5 AR TC R —MERIE. BRI ICREA G, #
YER K win_mouse_click.

As Object 7 WR kA HA GUI X R BIPT A A, IFANIE DR EIZEE “object”
K GEDERN G IBMAE T CEAAAEREFT— DRI 5.

Ignore it WR ZLHg X0} HAN 1) A7 4 o

%080 nr 4L 127 m



9.5 AIEKAK GUI Map L E
A R AR T AR E ) TSL i8A), JHEENTEA RS IIA T . IXFE—K, WR gl fE
i IEAf1Y) GUI map BLE
H— A K A GUI map fic & 1) 7774

1).  %H Tools>GUI Map Configuration §]FT %} 1HHE .

2). EFEAE, Riddi Configure.

3).  MESEIXANHIE, PRI LUABAEXIRHERRH WR H3h LR T iR IXAHLE ) TSL 5

filo
Configure Class x|
Cla=s Hame: lizthox Default | 0k |
Mapped to Class: Ilistbnx ;I Cancel |
Help |
Arvailable —Learned Properties
eplarad & a Obligzatory: Optional: Selectaor:
width class MW _1d
:um_c-:-lu.mns attached text ~ Tndex
¥
abs_x % Locatio
MSW _cla==
abs_y [
Insert I Insert Inzert
BRecord Method
’75 Becord {~ FPasz Up {" Az Object {" Iznore
Fenerated TSL Seript
set_record_attr ("listbox”™, “class attached_text”, -~
e | set_record_method ("listbox™, EM_RECORD); __gﬁggégga

1| | i

4).  widdi Paste n] DUETE AR 21 5 S A
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9.6

1.
2).
3).

MBR B & X2

PRILBEMIER 5 2 SIS . WR AT H AR AN BEMH B o
HAETT

¥ Tools>GUI Map Configuration ] JT 5§ 1K HE .

TEIE P RO VR AR BR 1R 2K

miii Delete.
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KEhk
FKE A WR RN 2K GUI M4 E 2 E . WR A GUI X% 42 LU R LK

7% (Class) Eiti3a

calendar( H JJ7) —/MRUER calender %] % J& T CdateTimeCtrl 5% CmonthCalCtrl
MSW _class

check button check box

edit edit field(Zi %X

frame_mdiclient | fff WR BEHE & 144 1F mdiclient X§ %

list list box, ‘& 1] LU 5 il list B¢ combo box

menu_item FIH

mdiclient mdiclient X%

mic_if win A5 WR G IEAN T A T BRAT AT G 1) s i) A5 A B 2 A mic_if
library. XANFI WR & SRIEH XK.

object B EARTAE T XA FIR PR S, 8oy« HoAd”

push_button push button (§%Z%#)

radio_button radio button (HJIEZE)

scroll scroll bar 5§, slider GR#%%)

spin T ) 5

static_text HAPR B RISOAR, A RARATR SR — 4

status bar HARHPIRAE

tab tab Jil

toolbar THRZNS

window wWH, WTEHEECRHS, 4 MDI windows

VER: WERAW A SO NI R ARAT A, AT DR BA 3l 1 v g A g e rh Rt
%
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9.8

PrA e

RS TR FTE WR LE Context Sensitive MK 4 F ) @ . £k lin 150 &
P B E AT B8 k.
R XRunner H O AN GELE WR HHEH

IR :Z) 1

=123 iR

abs_x XF G e b A0 N B A AR x BAE R AR AR
abs_y XA AR N B 2o EAATR y BRSO AR AR
attached_text | FENTXT BRI SUA

class WZHREM

class_index

FRARRRT G 105 o AT AR A ) 0SB (17 AT % CHAE JAVA
IO T

count SR AL B TR I H I A

displayed —AMRE, HSRIR N SO BoR: 1 FoRdEbise BT, 0%
AT

enabled —/NRE, HERIBHA GO S 1R, 0 AnTH

focused — AR, FERR BN R HRRIA N % 1 R S
MR, 0Wf

height WEHIEE (DL E R AT

html url —/~ URL (H7F WebTest {54t )

label PO SR TSINIBWN

maximizable | —/MMI/RMH, HIRIE X G A w1 RoRATLL, 0 ARTEL

minimizable —MNRE, HRIRHE R G B i ME: 1 RoRATLL, 0 AnT A

module name

—ANAHRAT S AL RR, IXAS SO T 45 € 1 4

nchildren NG IE WA Tt 80
NSTBTitle WA — AN TR AR L7E WebTest 1)
NSTitle Wb (R AE WebTest 1)

num_columns

T (R ALFE Terminal Emulator #4-+1)

num_rows

FekgXI % (A AE Terminal Emulator #4FH)

parent

KRS B HIE R 4
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part_value —419[f] radion button 5% check box [F1 4 FK (F{E WebTest H1)
position ST H AR b N BRI AL E CGE— AN H AR E 0)
submenu ARAE, HERIR ST H 25 738 1805, 0
value FEANTAI R 5 AN ] »
Radion A check button: 1 &/x &ML, 0 KR ApEE
KHITH: 1 RSP CLIE, 0 AL
List %% $ig kS50 H B SCAF75
Edit/Static X 5: fif H SCARX K1 A 2
WS SRR E
T oA % value J& & — N5 A 45 Hi (null string)
width XRIGERE (LLGZ A AL
X XSG AR I 5 R x RlAR AR
y PG AR T 5 ) y AR AR
F#E) R
= iR
handle — AR R IWIZATHRE: HWND handle

TOOLKIT class

R € toolkit IR - FEVL BT RGEHIXANETEKIEA MSW _class IR
I

ANH# 3 H Microsoft Windows J& 4

== #d

active AsRAE, 5 H T R A O
MSW _class Microsoft Windows &

MSW _id Microsoft Windows ID

obj_col name

DataWindow FIFI & X1 . PowerBuilder #iff: . X T edit field
X5 T TR B 44 8K

owner T R BT Je R 0P 1) 44 B
pb_name TR 14 PowerBuilder X% 43 FL I 45 Hr » HAE PowerBuilder fdiff:

LGS
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regexp_label | £l WR HIuJ 22 b R X G (1) 545 J A AR IA 5

regexp_ MSW | Microsoft Windows class 45 & — M RIERL A, WR g nIA & T
class AF MSW _class % %

sysmenu ARAE, FRH NSRRI H AR RGN

text X BB AR R AT WL SCA

vb_name R N 5145 Visual Basic X% 5 BL )45 5, X AE Visual Basic $6ifF
EEpVE
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9.9

BRINE S R

NSNS B

* DAY= T WA
All buttons class, label MSW id location
list, edit, scroll, class, attached_text MSW id location
combobox
frame mdiclient class, label, MSW _class location

regexp_MSWclass,

regexp_label
menu_item class, label, sysmenu | position location
object class, attached_text, location

regexp_MSWclass, MSW id,

label MSW _class
mdiclient class, label regexp MSWclass,

MSW _class

static_text class, MSW _id label location
window class, attached text, location

regexp MSWclass, MSW id,

label MSW _class
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9.10 Visual Basic %1% )88
fIif5 Visual Basic %1% (1] label Al vb name J& P+ 0520 & 1
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9.11

PowerBuilder X% i J& 4%
T fi A& PowerBuilder A% [RIFRAERT S N7 2] @ 7k«
ES WA E M AR HERERY
All buttons class, pb_name label, MSW _id location
list, scroll, class, pb_name attached text, location
combobox MSW id
edit class, pb_name, attached text, location
obj_col name MSW _id
object class, pb_name attached text, location
MSW id,
MSW _class
window class, pb_name label, MSW _id location
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10. FEXERSZR
10.1 RTEI BN S
B EAF AT REA S AL, T HAE LA SR GUI XS . WR S X 647 [&] AR I A
H win_mouse_click #f). @it B 5@ g A% S (virtual object), 7RI ELik WR
Bt GUI X AR BT A o 3XFE 2K, DMK AIAC It LU 2 D B AT A
fltn: 2 prskib] Windows HAH FITHELASEAERT,  t1F WR AREIE caleulator button i1
Al GUI XS, & At st button i LA AR .
set_ window(“‘Calculator”);
win_mouse_click(“Calculator”,87,175);
win_mouse_click(“Calculator”,204,200);
win_mouse_click(“Calculator”,121,163);
win_mouse_click(“Calculator”,242,201);
TXFE I AR ME B AR o A U0 AR calculator button j& BRI S I I 4l button
I, WR O S ATTIA S AR AU LA T
set_ window(“Calculator”);
button_press(“seven”);
button_press(“plus”);
button_press(“four”);

button_press(“equal’);

YRAT LA % FE #L push buttons, radio buttons, check buttons, lists ¥, tables, X L& HR K Fa A7
PATERIN R AT T AT R A RIS HAE &, ARAT BRI — s T 452K )
FERURT S

YA H] Virtual Object wizard CHESURT R ARIT) & SCHEAURT 5o AR S mRIESE— A
MRS GA R IFRHESS o SRS A — P Oehr e W RIVE I o« S5 IR g X Gk £ —
A4 . WR LT B G 2 M BRI ) GUT map .
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10.2 & X—MEUXZR
A5 FH R AV G AR I R 458 7

1).  i&$¥ Tools>Virtual Object Wizard. +1JF5F1HHEZ J5 fiili Next,

2).  EREHERF, EENESFT RIS WRIRIERE list 25, R ELERATEL WRR
EFE table 28, gl ZLAFEA] WHIATHONZIE. AR5 Aifi Next.

¥irtual Object Wizard x|

Learn Virtual Object

Select a standard clazs abject for the virtual
object.

Clazs:

sh_button

<t—sw[F-fw ] ms | = |

3).  xiti Mark Object. 1]+ 7 )t hn kel g REAUUG B IX o AR T LA 5 17 BB LE (X
IR o PR 58 P42 101 4 B SR A Bt 2 S s R FUL X R R A A

R B S XEAZR GUI NS E R . WREZRKLE, WR A HES R Hmih
1T GUI X BRI A e
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4).

x
Mark Virtual Object

Click the "Mark Object" button. Use the crozshairz
pointer ta mark, the coordinates of the virtual object.

Do not include zcrall Bars ar labels.

Mark Object ... |

Wfindow: IWinHunneﬂEFﬁﬁEﬂ - Microzal

& (544 — Width: |a4 E
T |214 E ﬂeight:|4a _1;' High_lightl

WRR A LRI, R GT Highlight 3T LA A 2. siidi Nexto

LB R RIS . ZADA T HIAENNR A . R R A7 WR AT L

TR SOAS, AR 23 U X S SOAA 1B A o A5 W, AR 2 U] virtualtable,
virtual_list Z 8. FRUATLLH CokE B4 . WR 2K A2 15 A 4 7] A2 844 il Al ]

SERR s i Nexto

¥irtual Object Wizard x|

Assign Logical Name

Define a logical name for the virtual object.
Thiz name will appear in the test script when pou
record actionz on the virtual object.

Logical Mame: | RS

Fhuzical Dezcription;

{ -
clazz:table, j
wirtual: TRLIE,

whdd

wald,
] i L




5).  SEMUE, WERVRAESE SIILAR KRR S IEFE Yes, xith Nexto 225G P AR with

Finish.

¥irtual Dbject Wizard x|

Congratulations!

WinBunner now recognizes pour bitmap as a
wirtual object.

Do you want ko learn another wirkual object?




10.3 B BN S P B IE
AR X R ), WR S YRR A N2 GUI map . RSN 5 (KIP) BE A A
T label J@ k. e — AR EE virtual. XA EHEHERBUIR RN %, B E
/& TRUE.
13 WR U] RE R0 GO e & (1 RO AIAE B AR P AL, DAL x, y AR AR, T8 AT
e BEAE R AU R PR T 22 . 04— virtual_push_button FIH) LA L5 .
{
class: push_button,
virtual: TRUE,
x: 77,
y: 111,
width: 50,
height: 30,
b
T I JE VR I B, WR AN BE R BIX AN BRI R T o W RN S48 ) sk
RSE, AR — AN H R R 5
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11. BN
11.1 FEIEMR

1.
2).
3).
4).

ARnr AR s i sl A 0 7 X Bt 38 SRl — N SRR A R4 o Aot 4l
BAFIEAT AR, TSLE il NIXEesist. IRTCLERIA BN, nTheess.

A PIRR] T R s A

Context Sensitive =% 1700 GUI X S #84E .

Analog F] XA Y FlE A7 SR ER BUbRIS AT U

PR DAAE A R AN GULL AZF S SO i e & i R0 e e i LR R LR
PE 24 RRAS A LT RRAS I DO o 720 i PSR AR BRI AT i m] 8 25 742 R I T 2 R
AL T4 ) R

PRAR AT DAG e B S i ke 0k A P S ok 3R 5

O A i T2 2D %

PR VRN DO RE Ao 8 PR ARLE VAR v A5 P A 2 R ) 2 1
1 IR P 1 HE LA A OG5 B SOk

PRI (Context Sensitive 8¢ Analog) JFf-3%Hil.
25 il — 44 T IRAT
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11.2 fRYCHE W PRI B 3% 1 1 1
1.

2).

WR RNEESRFIERIR TSL iEH)

2 WR ANBEIERUUNN LI, w2 5B obj_mouse 161 o W BE M A AE R Ji PRI AI e ok

JHREA LT LRk

A RE R A

] RE IR D T3

SCFREX B AT BAT I

PRI 2 25 FF N HE H bR AT S F . L an 2R
A HTML X%, i 24k WebTest fiff:.

X ET A AE SRR .

IR A g O G BRAER GARLL, AT LTI
AN B RE SIS B PRTEER

PRAT LA In—N B 2 X GUI X428,

PRAT LA —AS H 5 SGRBIMAT D E . W RARIN
MEEAE T, AR SO TIfEsi AT Ll T .

WR AGEM HTML T [ 2 B A

A RE R A

] RE IR D T3

WebTest Jffi {1511 12«

PRIBIR 2N SLFF Web ST R KT

WR AHEIR S HTML HEZE 8 4%
HRRSCA

i/ Create>Get Text>From Selection(Web only)fi
2 M HTML U S G $I5CA %1 frame, WR
i\ web frame get text i5f). X T HALX %, WR
i\ web_obj get text ).

1 H Create>Get Text>WebText Checkpoint iy 2> 15
T AR E 745 B A AE T HTML B b o % 1
frame, WR ffi \ web_frame text exists &), XJF
HABXT %, WR i\ web obj_text exists i)
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11.3 I
Analog B BIBER A . AR ST A PR ISATEZE . ] an AR AR A5 3% 4% Open
i, WR K BIASEAL T
#mouse track
move_locator_track(1);
#left mouse button press
mtype(“<T110><kLeft>-*);
#mouse track
move_locator_track(2);
#left mouse button release

mtype(“<T110><kLeft>+);

7t Context Sensitive £l Analog #53 A] LA E A L) o

%097 uu 4L 127 T



114 RER

FERRA AT LU N AR DY A0 7 i

o GUI Kpfr S S GUI X %4 Bt R LS — button 42 75 1] FH al— /M5 B
WIRAN I H Bk E T o TE WA GUI X4

o (LR A S A BB AR, IR R B R AT RRAS AT LU T AR AR
(AP

o SURKAE B GUI X GORI B 1 SCAS, SR TT AR I SCAR I 2% . T WA B STAR .

o BRI SR A — i B AT RIS AL RN A S XA tRARAE B R A gD 1)
N TENREEIERE.

#
\O
0
p=i
\|

/

—_
[\
|
=



11.5 FaaaKahila
an FARAE ] 22 20 0 A R i # e AD B, RT LA B X sh It a2 A A
ITHRE BIIREL, R ATHS AR R BE 3K5) . O 748 WR AT LU X S5l fR s
IRAE R BAS ST R R o IXAE R SR . Bl ettt A7 A2 — Dl R
oo HARERAVERMR AT LT T A] LU DataDriver Wizard >S540 IR DA A A Bk it 47
PR TEN BB EERE ISR .
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11.6 [
525 Lk AR AF R B R I A e 2 6 IR 0 o5 PR B A B e SRR B A — AT T8
P BERRAE TR, AR 0T LA N AN [R5 L S A 1 30 e e v o ic s v e L
Behnak.
ST RAIR, i a LUE ] [R5 ik WR B — AN R R 3 B R
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11.7 FHRI—AIhK

PEFF U 3 ) 5t 5 A QA 2 A7 i  E RIS H RN AR LA R
o RANRFE LMK T RE o Il Bevh TR, KR — DhRE A M. R AR

Ko — ki 2 ATt s

o PUEAREAE N AR H] AR 2 R )2 R

o IRARTIRIE A S T 2, i PE AN A T Analog B, WIEAS A4
Context Sensitive £ .

o YUEAEMA RS IRLACHY, IR, A0 B8 X Y)hE.
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11.8 JURAME BT

1.
2).

BN TT, ARAT LA AH A5 B ZE M5 )& 11 (Test Properties) %) T AE 1 2% & A4
AL pRET DU AT B 44 7 AR, 6T A T T R R A T e A ik
BEEP

ARt AT R0 e o T A s b A PR, 2 DA il — AN, e X
MAR g, BN — i iR, 5w I 4 A5

SCREAL RS B R AE T ik
1L F¥¢ File>Test Properties T1 1 J& X TEHE
Rl General £,

Test Properties x|

reneral |De5cripti-:-n I Farameters I Add-in= I Current Test I
noname:
Loz atiomn: d: M ercury [nteractivebwWinB unnerstmp
Athor; WozZa
Created: 2003-05-29 03.52:49

Read write status;  writable

Test type: Compiled kodule
bdain data table: default. xls j
= HOiH P () #Eh
HET3 Hik
TSL W) 44 FR
Location WM LRAFAE TestDirector H', B n7EH AL E . A W B s 7E
ARG A E
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3).
4).

Author MRAVEE 144

Created s A A H A A

Read/write | FEWIIRAZ 5 Hikte an Rt By, A M e 1 b A7 ] 2 45

status R DX IRAAN AT H

Test type TR IR A JE Main Test 1452 Compiled Module. 7 LB —ANR 1%
pURiy 528

Main data | WosillR 3 2R K

table

&1 Description £ Jf7E R N ZHI1E &
i OK PRAFIXEEAE IS PRI HE .
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11.9 YA
FEDNR e PR T AE AT DL BER B 7 i a1 o
x

General I Description I Parameters HAdd-ins ||:1.'|rrent Testl

Required add-ins:

[ Actives Caontrals
FPawerBuilder

[Vizual Basic
['wiebTest

W B | mAw | #=m |

YRAT LA TestDirector N FTIESRLE. 41 WR 44T, (HIEARINE A FE1E,
TestDirector 25K 4] WR, @I EHT 580 WR. WifdfF A& %%, TestDirector i

BRI G R “Cannot open test.”s

104 U1 4t o127 W
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11.10 FHIPR

1).

2).
3).

S AT 5

THGHIET, R GR TR .

i f] invoke application 1 1) 4] JF AKX AF .

SR E AR R AT, A B AR IOFR BRSO S—> win_activate ). 3X 2 FH ORI

AR .

(EUEEC I NDINS B2 = LN 1 7 s Y67, 7 S P 7w et A 1K = B B RPN T NS

S, AR CAHE WR S/ MU User T H 4 (FRESEIE T HARZEHR T, X

FEARE AT DL bR e T i B8 S LR B, SRR AT Ll A TR

FHIN A .

sl R, AR AN RPN RS AT AR, ANEH] Tab 8.

1t Analog BT N, XA FABERG AK A A0, AZET WR SR T H 4%

% Analog B RNy, BEGUBEHTHIAN . WARRTTZATH—AE 1, S E Hoea

FITPJG PRAREEER AT o St AT — A BUARBE AN JUHE 20X 24 it i S HR A IS
(i SRR B %% ERFE B BEdt WoR N ) o PR IR 2t i — N G (B0 B ]

&N (time-sensitive) #RAF. WURITHH N PR BIESHRAE, WRIZ Sd L.

WR SCHf RTL-style (AAARI/E) () GAJEME . FECE A B SRR A8

(KR EN 2% MM SCARTE GUIA B AT B Al o WR I SCRF NI 7] i 4% R CTRL il SHIFT
(5% ALT ! SHIFT) DJHiE .

WR SCHE N R ISR T R4 (L 1B) . ARSI THAE BRI —g

—H, HPIEE TAFEMZE, M H WR sEERW AR . TR Bk e i H 25tk

S toolbar_select_item 511, SN & menu_select_item 111

I IR AR ST A S B A S RGP AR I O B2, WR AN BEX & EAT AT

18 SR A

s R B A TV

1EFE Create>Record-Context Sensitive 5%, Create>Record-Analog 5% 5 i; Record-Context
Sensitive %4 .

A8 Y BRUPRRH B B AR A T RIPAAT A o A8 F] T R A B S B rh 4 ARG A ORI ) 22 A
1EFE Create>Stop Recording 5 /517 Stop 157 1151l o
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11.11 FREEENE A B w4

PAUR S PR e At n] L E SCHC B AV

w4 BRI phudt ke

RECORD F2 FrafsRile AE SR il R vt F R A
Context Sensitive Al Analog 1\ 2 8] 1))
#e.

CHECK GUI FOR £ Alt+F12 | K s —A GUI SR RA @ 2k

SINGLE PROPERTY

CHECK GUI FOR A Ctrl +F12 | A R ECE A QI — 4> GUI K s

OBJECT/WINDOW

CHECK GUI FOR F12 FIIFEIE GUI A0 7 A

MULTIPLE OBJECTS

CHECK BITMAP OF /e Ctrl + F12 | flfi42—AN 0 Gl w4 47 18 .

OBJECT/WINDOW

CHECK BITMAP OF o Alt+F12 | e — AN IR

SCREEN AREA

CHECK DATABASE(%k A Ctrl +F9 | B HEAN B A A £ o

)

CHECK DATABASE(H % | £ Alt+F9 A H s R — e BE AT RN, DL

X) TE A

SYNCHRONIZE A7 Ctrl + F10 | #8785 WR SFRER S sl i 7R 1) — A J@ 1 H

OBJECT/WINDOW A

PROPERTY

SYNCHRONIZE BITMAP | /A Ctrl + F11 | #8578 WR S5 A5 AN o 1 % ml i 447

OF OBJECT/WINDOW HE

SYNCHRONIZE BITMAP | /A Alt+F11 | #5728 WR £ — N (1 DX sl 1] H

OF SCREEN AREA

GET TEXT FROM F11 TP BB R R SOA

OBJECT/WINDOW

GET TEXT FROM A AL+ F11 | A —NReE X SOA, JRAE A 4

WINDOW AREA A% obj_get_text i&f).
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GET TEXT FROM A7 Ctrl + F11 | A —MRe e XL SO, FRAE A 4
SCREEN AREA A% get_text i),

INSERT FUNCTION FOR | F8 i GUI X 48 A—A™ TSL Difig.
OBJECT/WINDOW

INSERT FUNCTION F7 FIFF T RE AL A 0 TE AE

FROM FUNCTION

GENERATOR

STOP JiCul +F3 | fEE kgl

MOVE LOCATOR o Alt+F6 | Skl — 4 B HERR M RT A E )

move_locator abs 5]
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1112 A G2
AT LA 9 5 AR 14 7 7 B — A 5 2 1) A B0 16 i sl A . WR B — A
RERL YR FE T H —IhREAE i #% (Function Generator), RJ PR AR TEAR M e JHIAS TR 5 in
TSL Difig. WIS, H sl — A R e\ TR B ke, T LAERIIEE.
PR AT DA T g FE— FEAE AR FiE R BN H g X Dhfg. PR H 7 i Lt
ELARA AN B AT L
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11.13 4R3I
LEME SO BAS S, ] DE H g s sl T B4 FAHN a2 N2 n] H a2

G Eitipa

Undo HCH A — IR R A

Redo FURT— K Undo 11N 25K o
Cut B,

Copy il

Paste i o

Delete T <

Selete All 21k,

Comment FEAIE TE ) AT AR AL TR o

Uncomment OB AR AR

Increase Indent | %I & [0 SCA ) A7 1L 4 3E— ) tab 23]

Decrease Indent | JEH7 L [ 3CA W] 223405 5))— > tab 1750

Find BHAFE WA

Find Next AT A

Find Previous AT

Replace B,

Go To NI B B A RS E—AT .
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12. K& GUI X%

12.1 RFRE GUI W%
AR AT UL GUI K2 R s gl I o p 1 GUT W5, ik o] LUK 7 — A 175 A
LEATINATIF, /> button £ AT %, ARFTEMAT R RIG XAN %, TEPRIRAIE
WR R 2R (0B FRTT LUK 25 WR BB M sk 1 e S e . GUT X Rk i 1
R PEARAFAE— AR ZE RS B Lo AR T WR B 52 10 24 3 J (0 B Ak A S T2 0
SKIN AN GUT K 75 25k S B B A o o (5 A tP AN B 28 5 5055 obj_check_gui
&, win_check gui ).
PATTRAIE, 2 p kA S B (R S LR . RN 2 sk A 2 K K A 46
FATUAYEINAL: A OB E . 1A HTIRG R
e 2 R0 % SR ARTE GUI map 2 E 208 & GUT map S0
RAT AZE—A edit W5 static SCAR % b M 50 G0 GUI KRS A 7 WA
HRRIEN.
Rt T LR R 2 A AR R BRI 2. AR EER I 25
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122 ERNEENE
T A R IHEA B, {1 H Check Property CKY @ M) X IEAE IR 1 (1 H=ANTh
REZ A
button_check_info
edit_check info
list check info
obj_check info
scroll_check_info
static_check_info

win_check info

HARRAE T
1).  %H Create>GUI Checkpoint>For Single Property. WR T 1< Hc/Mb, AR 2
RCT . WERRAE ] Analog #5230, A4 Alt + F12 KBS AR 2 5] .
2).  Rii— X% AR5 Check Property W iEHES ST I ol LAFEXS B FAE F R ERIA )
AE. WR HZh&ThREAR I .
x

Il:-bj_check_inf-:- (“RichEdit20% A", “enabled”, Clase |
Object [*Ri chEdi 120%_6" @ i

Froperty I"enabled" j Change >>|

Expected |1

3).  ARAT LG SRR S A S
o 1t Property i L HLIA PR AR EAG B 1) B PE . JHEE{H S5 7E Expected HE 4 58T
o nifli Change 24T HF I REA: O TEHE I WoR DI e T 5
o MBIEFEAFMING, sl TRERS, RGNS L.
o RN ZMPTIERITIREA B, SR HA IR REHIER N Z L. il OK K]
THEAE, iy Close JCHXIHHE, SRJFHEDER 1 F 2,
4).  widh Paste LiTAPREIGEB AT
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12.3 KEEANNS

PRATEAEISEE GUI A 2 i Rsr 25 4 I A0 o B BRSO 5 o ARl AR A0 G RN P,
LR LA B k.

TR ERT SR — B & )E . i gui_ver set default_checks Jjfig 1 & Bk
N R R

12.3.1 i BRI 7 ) A0 GUIT A A A

2).

3).
4).

PRay LA — AN A RORA A WR BB LA @ o 34507V

1EFE Create>GUI Checkpoint>For Object/Window, 5{t. T H.4% I riili GUI Checkpoint
for Object/Window. WR & Hoxf/Mb, BUARTREI AT, Bis bos Il B &
Ho

M5,

WR B ANR G 2 5 @ PR Nk, IFORAFE IR 45 S B SR )5 WR &
WAL, IFHAEIA N obj_check _gui ).

12.3.2 @) sdtAs & sk BfR 8 s 1k

).

2).

PRy LAZE R A s AR e AR TR A R B 1 o 34 v

&Pt Create>GUI Checkpoint>For Object/Window, 51t 1 H.4% I fiii GUI Checkpoint
for Object/Window. WR % H<xf/Mb, USRS T, Bigs bos It B i
M,

Wt *t G G k. Check GUI X IEHE 24T T

4iCheck GUI - d:\Mercury Interactive' WinRunner',tmp'nonamez2' chiklhist 5[
£ 0
Add All Select all Clear all
pbjer_'ts IPrn:-perties #
ElD: winfunner {8 1 BA - Micro | Mame I Arguments I Expected Yalue | ;;]
P YrichEdizow 7 (1@ Enabled oM L=
Il ':a Focused OFF EE
& Height 16
G width 286 il
@y 318 o
v 103 B
l | B
¥ Highlight Selected 01 0K | Cencel Help |
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3).
4).

5).

7 Objects HEH 35— MY 4 FK. Properties HE - 52 HBLX AN G 1 BT @ %
AR R A R e

Mg — AR, Seikrhax AN EtE, 285 0T Ll AL Edit Expected Value 124
o2& Xt Expected Value 1) 7 i 54N 24 .

AR fR e A, Jeikrh E Y, 285 B Specify Arguments 28 5{ X Arguments
Hlo TR WIRAE Arguments £ I 3 A IARLLNEE XA @ 4R € AL &= . 0
ROLAHBINRRHATGEIRE

i ] Show Properties $%4H 1] LA R A F 77 2.

sili OK K PR EHE o
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124 WE-NEEFRIZINER
PRAT LM H] GUI A pi i & B A b g A s 20 5. #84E 57

1).  1%$% Create>GUI Checkpoint>For Multiple Objects B4t T F. %<1 15 GUI Checkpoint
for Multiple Objects %41l . @ GUI 7 i ST IEHERL & 4T IF

2). s Add % .

3).  RRIANER, BN WUERR R E bR A B A L, HE A DS PROR IR
R AR b T A N %

4).  SEE AN GRIFIE A DLARSEIEFE T R G AHRARAN T DAAEAN ) 2 A e Seddi
B A — M R

5). Rl EARAEE IR, G0 GUI KL SUNHEHE ST IT

L Create GUI Checkpoint - d:'Mercury Interactive’, WinRunner'tmpinona il
= = 1) & w T
Qpen Save As Add add all Delete Select Al Clear all
Dbjects Froperties u
= w2 winRunnerSEF{EEE - M | | Mame | arguments | Expected value | E
r+ M =nDockTop O a Enabled oM =
&b (1@ Focused CFF =
LY RichEditzow_7 @ Height 101
&& RichEditz0w _5 & width 1024 i
e ;gg;litznw_g @ 4 =
4 it ¢ 23 1
& BH ® b
&y web - IE
I _>I_I

¥ Highlight Selected 01 0K | Cancel |  Help |

6).  Objects £ rHZ A 25 K A BARFIN G PR AREENRAS 0 Ay, ST A4 R AT Y
ZJ3T L. Properties £ B2 X% G 45 g P o
o REEGIE DB, Stk XANEME, R TLLA Edit Expected Value 4]
it X Expected Value 41 (R 3/N HIEEAE
o AEEIEMETPREAR R, Sk B, SR)5 A Specify Arguments $%41 5 X7 Arguments
Flo TRL: WIRAE Arguments A2 IR 3 AN, EARIE A NER IXA JE 4R C AL & .
ROEHINZEYATERE.
e i [f] Show Properties 1% 7] LA AF & 77 2o
7). il OK KHIFHRAE. WR {EBIA I win_check gui i1,
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125 A NEETRENSR
AR] DAFHAS £ 5 A AR BT GUI X G I BRR 2 P 25 B FR e A 1 N 25

12.5.1 BRI A 77 A 2 A v A7 0 42

1).  I%&¥¢ Create>GUI Checkpoint>For Object/Window, 5% {F 1. 2.2% |- )5 GUI Checkpoint
for Object/Window. WR % 1< f/Mb, BURTREF ST, bigr bl
Ho

2).  RURARET A PR A B A . Add ALl ATIEHESSFT T

x

Tou are currently peinting at
fhat do wou wish to check inside the

[+ Objects

[~ Merms

Cancel I Help I

3). RPN R A . PRI N B S A T
4). 1 OK FEHIXEHE,

1252 fRER AN A

1).  I%&¥¢ Create>GUI Checkpoint>For Object/Window, 5%{F- 1. 2.4% |- )5 GUI Checkpoint
for Object/Window. WR % < f/Mb, BURTREF AL RTH, bigr bl
Ho

2).  RUGEARARRS A 1) B BRI B TR . WR S 2R AN B AR DA R R A A
. S5JLEME, Check GUI XFHHESAT T

3).  FREREARANE, mOK KA.
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12.6 HEf# GUI K& SER
SURL A P GUI X [ 25 5 7 ) 2 obj_check _guio 6 25 2 AN G R4S 7 a5 1 A
win_check_guio 9N A H RIS i 5 L KAk A7 T 465 S5 10 SC A DGk
o KA T E O A IO S A B Y. UIREIE GUI KA SN, ARTT LA — AN
R AT SR, ] A IAE I o
o TS RSCAFE S TR A B LA G PO A o IK AR A B A A U B
PETK, ARATELTF T ROBXEeE, ] LA SO B AT WK i S8

obj check gui &R AJVEUIF

obj_check gui(object, checklist, expected results file, time);

object 3t GUI MG & H . checklist /=R AT LI A T expected results file 3 fiff7
SRS A4 Time R WIHT— AN L 24 117 Ja A 2 ) i B K AE IR CRARD
RS o IX AN 1] (R BE A2 DR A T B B8 I 21 timeout_msec MAAZETH . 7 WA A
Hh B B P T .

Blhn: EHBPIIETRE o, WRRAEE R O Al OK, i f) it

obj_check gui(“OK”,”listl.ck1”,”guil’,1);

win_check gui i T A)VEUIT

win_check gui(window, checklist, expected results file, time);

window & GUI TR [NEH 4 . checklist RGN T o expected results file /&1l
A ES ROCAT R4 T o Time RWITT— U AN 24 A PEAR 2 18] 1) e KB IR (LA
FOTHEED o JZANIN ] [ g /R AT IR B 5 N 2] timeout_msec PRIETH o 1 UL
A BB HIEIR -

Blhn: EMBPETETREE o, W R R R S R O RORR R, TR AR

obj_check gui(“Login”,”listl.ckl”,”guil’,1);

ER: WRATIAH R — M A #dy 4400 listl.ckl, 55— DMHUYPELE RN guil .o
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12.7 7 GUI R E R P EAFER GUI & H
PRAT AZET B () GUI A A s P A H AR AR GUI K i i . S H R A e ml LA
SRt AR . RARARAE 2 NI b SE A AT R, AR A SR AR AR S S
il L&A AR (R 20 TR R A T v

1).  %&F¥ Create>GUI Checkpoint>For Multiple Objects 5% {F 1. .4 I 5. GUI Checkpoint
for Multiple Objects %41l .

2).  mithi Open.

3).  MEHFLZIRP R AE S, & Shared.

Open Checklist ]|
Erter Checklizt M amma: ITI
Cr—
ligtt ekl Hak
lisz 3 ckl

Erter Checklizt [ ez cripbon:
Checklist For wardoss "Lagin'

L]

[

4).  EEE AT, AT OK G X HES R HA], HIL I 2 tHL/E Create GUI Checkpoint
XA

5).  FTOTREINEAT b A e s 0 B BRI AR

6).  niii OK. WR BLEi#e i@y, JFAEBA A win_check gui #f).
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12.8 B GUI e EiE

PRAT LIE S5O 257 BRI P 2 o R Ay s ARG TR B A I SR . e AR
PERDHEEE . AR A AR B T MBS, B GUIL B KIS R
& GULIE N, /RAT LA

O AR AL S e

G

12.8.1 JEIH AR AFAE I 2 30

1.

2).
3).
4).
5).

BRAE LT, o 23 B ORAFAE A A SR . WRRAEIE 523 S R BRA S
Je & WR 2 3E A JE/chklist. R A] LA General Options X1 HEH [#] Folders #2911
Shared Checklists HE 228 LR AF SO

DRAT B LSO A 7 7

UL+ Create>Edit GUI Checklist. it & GUI AL 203 A7 .okl Ja 28, Hds P A6 20315 F AT .edl
e 4o

%A GUL K &g 5, AR5 R OK.

i Save As TRAFRT AT

7£ Scope HEH £i Shared. fI A4, i OK.

s OK ] Edit GUI Checklist % i AE o

12.8.2 %% GUI #6753

W G, ARTT L

AR B A TP T A AR R B

RS G R A R

VSR S P e A A A

BTN JE e e AL

TERG, TEORG 4 T 06 200 56 N A80AS v H

1%4% Create>Edit GUI Checklist. FABARAERIFTJLASF T AR S 2. Zwi
TEHE

il OK, KAl o S P RAE, WR S HRRE 1578 o5 JFOR IS

&L Save As H AR FIRAE

R A Verify BECIE4THT, 58 Update #5557 1122 45 Lk w & AR BT AU A& 250
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12.9 R GUI K& SOVEAE

B 4EY GUI K1 1

Checkpoint X iEHEFI Edit GUI Checklist X} TEHE
12.9.1 %4 HE AT e H B AR AF S

— 3w R = ANKUEHE: Check GUI XfiGHE, Create GUI

fFR X T AE (ALY
Complex | B HIE(EESEPRE RS | Check GUI, Create | Properties pane,
Value UL T ICIEES | H B8 . 3X | GUI Checkpoint, | Expected Value
M B&w B IEA WA | GUI checkpoint column or Actual
AR Results Value column
N/A JEVER A AR $2 2 75 | Check GUI, Create | Properties pane,
PR e A R, B 20 )EYE | GUI Checkpoint, | Expected Value
NN EIRS AT R A R GUI checkpoint column
Results
Cannot JEVER A B SEFR{EARE | Check GUI, Create | Properties pane,
Capture Bl HE GUI Checkpoint, | Expected Value
GUI checkpoint column or Actual
Results Value column
No XTGBT E Check GUI, Create | Properties pane
properties GUI Checkpoint,
are Edit GUI
available Checklist
for this
object
No MET AT AR, XX ER | GUI Checkpoint Properties pane
properties | W45 E 7 E AT A B TE Results
were
captured
for this
object

R : KT GUI Checkpoing Results Xf iHHE 1 WA HTIIAREE R
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12.10 BHEME MR AR E

1).

2).

3).

b).
c).

PATT & AN 2] DA A 1) Js -

Calendar Class

Enabled: 1375 H P25 Re k.

Focused: A5 &8 i 15 AT LLE B H P47 4545

Height: 37 H s (REN LD,

Selection: | [ 3k & 19 H Y] CBRIAR D

Width: 5 H GRS (R AL,

X: KA Pie EARARRE T 6 ) x BlAA AR

Y: K H A AR T L) y RlARAR.

Check_button Class 1 Radio_button Class

Enabled: £7t button /& 75 7] .

Focused: 45 & 81 & 75 AT LLEH 0 button HEAT#4%

Height: £i#¥ button )= (RZ=NHAD.

Label: 7 7¥ button (¥4 45,

State: 15 7¥ button FPRZA GFEG, (BRAKAD.

Width: % button (1555 (R F4 AL,

X: K button 2 b MAARXS T L x BlAAAR.

Y: K button /o b AAHXS T )y BlARAR.

Edit Class 1 Static Text Class

K LR Fi4N @ PERF (Compare, DateFormat, Range, RegularExpression, TimeFormat ),
PRAL 5 E AL H o

Compare: FAXRIHE CRIMEE D). R0 Ble e LU R AR &
NI SCARMAE DUAH DG (case-sensitive) F AT CERINIEED.
FEN B IR DTS (case-insensitive) 1.

FENR IR R A

DateFormat: 5700 S48 HIRF 2 H IR XA 2. IR ZidR e & CH IR 0. WR
SCRHR 22 7 H 57k 2.

Enabled: o #0520t & EGILEFE

Focused: & i & 75 7] LLE BRI A G347 4F

Height: f A0 G0 (RERE LB,

Range: 100 GAERETEHIN N A . IROJFRC L5 Guil ERATTRD.
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4).

7).

RegularExpression: £ #7074 o 755 1 L U745 R o IR AR 2 AL & (4

PRANT BAERIE ST IS VA RIE R .

TimeFormat: £ 2% G FHHF e I kg I N 2. R Zifs e & (g,

hh.mm.ss 8¢ hh:mm:ss 2 hh:mm:ssAM/PM)

Width: K& REGERE (BN RN,

X: KA G EAAR T 5 ) x RlAAAR.

Y: RAN SR A AR Ty AR

List Class

Content: &3 list [N 4o

Enabled: FI2% list /& 15 RER LSS .

Focused: A8 4 & n) LLEHX list HEATER AT
Height: f5 77 list BB (B2 N IRAD.

ItemsCount: 7 list H130 H 150z .

Selection: F A 4 list PG E KT H (BRIAED.
Width: F 8% list K196 (RENHBALD.

X: KT list 2 b A AR T2 F 1) x flAR bR

Y: kA list 2 EAAAHR T ) y #ARER .
Menu_item Class

HasSubMenu: iy —/EIH &5 15,
ItemEnabled: &= H 2 (BRI E).
ItemPosition: 2135 H 1 &I H A7 E
SubMenusCount: 1513 b I H (140 .

Object Class

Enabled: 524 %02 ek d%.

Focused: i /& 75 7] LLE AR G347 4%
Height: K &X G (RENBPAD BOAEE).
Width: BN RN (RPN R ED.
X: R G EAAR T ) x BARAR (BRI 2.
Y: R AR A AR T E Ry AR (BRIAK A .
Push_button Class

Enabled: 1375 button s 77 REHESE (BRAKI A,
Focused: A8 4 J& 15 v] LLEHX button HEAT #24F .
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Height: 7% button 155 (G5 0 AL,

Label: f5 7 button 14545

Width: # 7 button FI5E 8 (A FLL.

X: F07% button /& L AAHR T L x HAASR.

Y: fo & button /e EAARFE L y SiliAARR.
Scroll Class

Enabled: fo &R 5142 1 RERLFE

Focused: i 42 77 Al LU B HONR ) S 8AT # 4
Height: i ERENA MR (RENBLLD,
Position: &Rz LIRS ETALE (BRUAGED.
Width: FfREN &I TEE (RFN A

X: W EIREN A A AR T8 T x BlAR bR .

Y: K ERan gL LA T ) y SRR
Window Class

CountObjects: 15 % A+ GUI Xf % CERIAMGED .
Enabled: 57 & 42 1 ik %.

Focused: o 28 42 15 7] LA B 0] B A BE T 454
Height: F & % RIS (RFEN AL .
Label: for & & A3 br .
Maximizable: 5 % % 42 75 AT LR KAL -
Maximized: 2 & 42 DB Ak
Minimizable: 165 & {42 15 il LAg /M
Minimized: & &£/ DA/ ML,

Width: & GRIKITERE (BRI,

X: fd &R EAMA x fiAb AR,

Y: KA AL LAy BAAbR.
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1211 AR ETRETE

1.
2).
3).
4).
5).
6).

Jy edit class B¥ static_text class $i /& A8 i [ 714

fifith GUI Checkpoint X 1l HE £ 7 AR AT 24 e A 1 (0 G J@ 1k o

7E Objects £~ HIEFX %,

7t Properties f=i%L & 1

miiti Specify Aguments B XU BRI\ A2 0l £ U4 L £ Specify Aguments.
FER AT 45 2 22 4

5 OK SC X T AE .

12.11.1  tbx}jEPE (Compare Property) £ %

$TJF Specify ‘Compare’ Arguments X ifHif[E .

Specify "Compare” Arquments E |
Corpare cortent as

& Tenl " Humsiic
™ Ignare Cas e

Concel | Hep |

it Text f08 N BAE A AR & CERIABCED
PEA ANy 2 AE DL,  EFE Ignore Case.
st Numeric 84 258 47— MR & .

12.11.2  H AKX MRS A

AR 2 H K, £F Check Arguments X} i HE 1) F7 32 B Fh ik
Check Arquments |

|' Pleasa choose dae fomat

[Dale Fommak: m
ok | Cancel | Help |

AL IR B A A DU LR
mm/dd/yy  (01/22/99)
dd/mmlyy  (22/01/99)
dd/mm/yyyy (22/01/1999)
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yy/dd/mm

dd.mm.yy

dd.mm.yyyy

dd-mm-yy

dd-mm-yyyy

Day, Month dd, yyyy Friday(or Fri), September(or Sept) 24, 1999

dd Month yyyy 24 September 1999

Day dd Month yyyy  Friday(or Fri) 24 September(or Sept) 1999

HE: Hys eIl o (9 A 09), XA 0 £ER Uk I AN L 46 21

12.11.3  JullEtEs i
R TR TR TS RS A I A i
Check Amuments |

Pleazs anter rarge:

From '

T |

[ ok | Cancel | Help

12.11.4  FREAEERE
FEXF U AE P N I8 N AN T BEAE RTINS o RURHT N\ BA A S B RAT “\”

|' Pleaz= enter recular axpreszon:

Fsgular '
Euprassing:

[ ok | Cancel | Help
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12.11.5  Wpapas =g v &
Check Arouments 3|

|' Pleas= chooze brne format:

Time Fommak: m
ok | Cancel | Help |

WR SRR U a5
hh.mm.ss 11.22.33
hh:mm:ss 11:22:33
hh:mm:ss ZZ 11:22:33 AM

12.11.6 XM GUI K3 s G HE
W BRI RE T TR e A A A B M R A A R e AR R, B OK X HE

I, SPoRIRTEE AR,

Argument Specification

Fleaze cpecily aigumers for the fallowing checks:

Check |_object | Argumerks |

i DateF ormat Agent Mame: -
'% TimeFarmat Aoent Mame: -
':ﬁ Fainge Agznt Mame: -

':ﬁ Fequlark spiezscn Agent Mame: -

Specily frouments..

Close Help
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12.12 43R )8 A E

1).

2).

3).
4).

5).

RGN —A GUL AL AT SR, WR A G P (R M AT A5 TR A M . TR
ATWARIN, WR P I L J R K 4 i, AU LA . i RARTE GUI K
RBI S U R SCE AN B P E, VR A T ZELE Check GUI X1 FHERY Create GUI
Checkpoint %} i HE 1 e 3 AN Jag 1 (14 JT 28 41

R VRABELE Edit GUI Checklist X 1 HEH g4 1B, AR R4 TS AN XS 1R AE I
WR FEAHAE M RE, T LUK AT HEAS S m 4 S 4 R S B AR . dn SRR RS i 3
LS GUI B 382, I AMRLE S GUI AR S8 45 1. VE s
B GUI & R R EE .

G R0 S A AR T 1

%+% Create>GUI Checkpoint>For Multiple Objects 3T JT X[ EHE. 1 Open §7 74 A
B, VER: Check GUI XU HE L AEARAI BT GUI A A s A 41 IF .

e E

16 5 it Gt 4 R L
o8 1L
21 Create GUI Checkpaoint - 2\LogindochkhizBist? ckl
=4 = &N £ r 4 W T |
Cpen 3EvE A Add Acd Al [zl Selectall | Cearsll
|Dbjects |Propetties =
-2 Login Mame I Argumerts | Evpectad Yalus | E
W& AgeetMamesati | W] 5 Enshied oM = =
- o
oo [ 3b] A et M ame: OFF =
- [#] 8 | Canzel 5
5
Tl
[
1 | »

W Highight 5elected Object ok | Carcel Help |

i

st OK SRR o
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12,1365 GUI & RIS R
PRAT LA e A A A s ) B A A R A R A R B A R . AT LA AT A Y
JE B
AR

1).  I&F Tools>Test Results 5% ;i it Test Results. WR JIiK 25 G 14T FF o

EE WinRunner Test Results - [Moname15]
Fiz Optionz Toals “dindow =2 x|

S8 [oxo o slEz e sl
[ Test Resut. 0K

|: +% Total number of Btmap checkpoirtz: ]
+% Total number of GUI checkports: ]
& General Information

Line Evert Detalz | Reosult Time -
1 skt GUI capbuie | guil 25E044: 3518
q end Gl cepturs | guil OE, 2a6044: 3518

I I v

2).  IEFRIREVEE RSO CBRIAE exp).
3).  7E testlog i Event 41|, #£%| “end GUI capture”. Line 41 HL & U3 A A 4T %0 o
4). Xt “end GUI capture” 8% fUIXMC 5% FF &1 Display. GUI £ 7% £ 25 R0 UEHEFT I

2 G Checkpoint Hesults

11152
L=

||:I|:|ia-:ts |F'r-:-p-9|ti93
=+ Login Mame | arguments | Expectzd value | Acualvaue |
oK 3 i oM

7

T
A

o
3

We |

r b
ilm)e e i

¥ Highiight Selecied Objzct ok | Carcal | Help |

5. EFETEEUENE. SOeE s OKe VER: ARAT LRSS ARG I SE bR e 2 iy
ERAE T — R S A
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